summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-18 04:56:26 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-18 05:14:47 +0200
commit96682962de82ee4185c74fadbab2e978da8c6dc1 (patch)
tree7d2e57e904d2ef2f09cabf995e8985bbfacebb2d /dev-python/httpcore
parentdev-python/google-auth: Bump to 2.18.1 (diff)
downloadgentoo-96682962de82ee4185c74fadbab2e978da8c6dc1.tar.gz
gentoo-96682962de82ee4185c74fadbab2e978da8c6dc1.tar.bz2
gentoo-96682962de82ee4185c74fadbab2e978da8c6dc1.zip
dev-python/httpcore: Bump to 0.17.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest1
-rw-r--r--dev-python/httpcore/httpcore-0.17.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index bf20db5dbc27..10befd7b1145 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -1,2 +1,3 @@
DIST httpcore-0.16.3.gh.tar.gz 79132 BLAKE2B c06d55ce1390085db6c15d3e96160cfb037a935d1298304856defd1778783ad1954924a48653ce165dae9cde18abec157aa72865f57e97d91a564d1b823c863c SHA512 d889da0a3fee4f190ecc3981b8af34fa9b285d00f4ad92158a085c65f3ad8fa5a97a8c711bd51f8b9518b9d2c90ecd457dee1a3d7bbf853715473f4707cc421a
DIST httpcore-0.17.0.gh.tar.gz 82103 BLAKE2B a12d2843cd19f98d86868802fbb5af37f7223e6cbdb64ec4a36bda93237543d940cc7e71647ffbee67de57b46900a9496f2d3019d9bf0ac4cb74f5d13232708d SHA512 4bec9830df75b35a470e745955058e86cb4cc59c0eacef8d67d76be91c9297009f9af2bf745bf553607a60ff5fd2eaee5b8a497bb8b48ba3daffa08e80188ef4
+DIST httpcore-0.17.1.gh.tar.gz 83752 BLAKE2B c534ce92d11a719a5049677a9d73269a991f607460d4560a3faad0917a992a0d609f91e6f98f9fed87a52e215e1a53d8287cf84268042ae17300ba7d1091e5ee SHA512 73935a22e6f91a4f9e49865066badc9b6f4ade342d294a2e419d5381ead18d2bd5f4e9cee4bfabfa66e8d0a0796d62a3def906dd0e9924b9e5c1d682ceb7edce
diff --git a/dev-python/httpcore/httpcore-0.17.1.ebuild b/dev-python/httpcore/httpcore-0.17.1.ebuild
new file mode 100644
index 000000000000..29b9667eb195
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.17.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="
+ https://www.encode.io/httpcore/
+ https://github.com/encode/httpcore/
+ https://pypi.org/project/httpcore/
+"
+SRC_URI="
+ https://github.com/encode/httpcore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.15[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "SOCKS support" dev-python/socksio
+}