summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-07 05:09:58 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-07 05:15:14 +0200
commit5322fa0fe0a3c1ca9b1cd4a74ac09f8bcc6a443c (patch)
tree11a2982500879436f4f8cb14d2976f2e4e4740ff /dev-python/httpx-socks
parentdev-python/referencing: Bump to 0.29.1 (diff)
downloadgentoo-5322fa0fe0a3c1ca9b1cd4a74ac09f8bcc6a443c.tar.gz
gentoo-5322fa0fe0a3c1ca9b1cd4a74ac09f8bcc6a443c.tar.bz2
gentoo-5322fa0fe0a3c1ca9b1cd4a74ac09f8bcc6a443c.zip
dev-python/httpx-socks: Bump to 0.7.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpx-socks')
-rw-r--r--dev-python/httpx-socks/Manifest1
-rw-r--r--dev-python/httpx-socks/httpx-socks-0.7.7.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/httpx-socks/Manifest b/dev-python/httpx-socks/Manifest
index b683dee94d8a..c5b9d7adcd28 100644
--- a/dev-python/httpx-socks/Manifest
+++ b/dev-python/httpx-socks/Manifest
@@ -1 +1,2 @@
DIST httpx-socks-0.7.6.gh.tar.gz 15116 BLAKE2B d94e13cf61a831cc36486962dd493ebfff4822a73c39f9be30fb2c13720330ec6e6ec1fb763ef1551f00fd97270a8b288e4ed7fc2b30c2f78cd8f608e88d77a6 SHA512 08e2d72d93896c15cc9e455f5d878d1015b72da48b17e53a361f7af2d0890caca42478a0f295332093afa19735a0a2fd4fddf13d09c7baf57575cd6534f9cdf9
+DIST httpx-socks-0.7.7.gh.tar.gz 15127 BLAKE2B 7cdc74de0860edfab5e7bf3ef00312fe813d322c25800fc62985cfe45cc2d16ff2fe03d8b24779e6ba1a065797c8e56a61e025da263d4437e5f04e13fba3f7a7 SHA512 70cccf16245fa364a5f91718e708d67c3ce8fc4bf5bf37a43c620b76b6b294df6d5dc971c1fd69bd3f75d5543b87a0d7eb2f3348492f807517224b0f7e62fe1f
diff --git a/dev-python/httpx-socks/httpx-socks-0.7.7.ebuild b/dev-python/httpx-socks/httpx-socks-0.7.7.ebuild
new file mode 100644
index 000000000000..dfe2e7e85e81
--- /dev/null
+++ b/dev-python/httpx-socks/httpx-socks-0.7.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Proxy (HTTP, SOCKS) transports for httpx"
+HOMEPAGE="
+ https://github.com/romis2012/httpx-socks/
+ https://pypi.org/project/httpx-socks/
+"
+# no tests in sdist, as of 0.7.6
+SRC_URI="
+ https://github.com/romis2012/httpx-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/httpx-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
+ <dev-python/httpcore-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/httpcore-0.17.3[${PYTHON_USEDEP}]
+ >=dev-python/python-socks-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/hypercorn-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.19.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.6.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest