summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-10-17 20:09:17 -0400
committerSam James <sam@gentoo.org>2023-10-25 03:22:23 +0100
commitb49e0fcae853221afa8ba791f10c873cd1b57614 (patch)
tree26f7e7c832e37045a68b495739915192740678ab /dev-python/hypothesis
parentnet-irc/limnoria: drop unneeded test dependency on mock (diff)
downloadgentoo-b49e0fcae853221afa8ba791f10c873cd1b57614.tar.gz
gentoo-b49e0fcae853221afa8ba791f10c873cd1b57614.tar.bz2
gentoo-b49e0fcae853221afa8ba791f10c873cd1b57614.zip
dev-python/hypothesis: remove outdated test dep on mock
Since 2019, it is imported from the stdlib unittest.mock where available: https://github.com/HypothesisWorks/hypothesis/commit/ea4c995e08bf74bd808eea8f91a98918969d957e Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/hypothesis-6.84.3.ebuild1
-rw-r--r--dev-python/hypothesis/hypothesis-6.87.1.ebuild1
-rw-r--r--dev-python/hypothesis/hypothesis-6.87.2.ebuild1
-rw-r--r--dev-python/hypothesis/hypothesis-6.87.3.ebuild1
-rw-r--r--dev-python/hypothesis/hypothesis-6.87.4.ebuild1
-rw-r--r--dev-python/hypothesis/hypothesis-6.88.0.ebuild1
-rw-r--r--dev-python/hypothesis/hypothesis-6.88.1.ebuild1
7 files changed, 0 insertions, 7 deletions
diff --git a/dev-python/hypothesis/hypothesis-6.84.3.ebuild b/dev-python/hypothesis/hypothesis-6.84.3.ebuild
index 266faabd3550..67d44f17a56f 100644
--- a/dev-python/hypothesis/hypothesis-6.84.3.ebuild
+++ b/dev-python/hypothesis/hypothesis-6.84.3.ebuild
@@ -43,7 +43,6 @@ RDEPEND="
"
BDEPEND="
test? (
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
!!<dev-python/requests-toolbelt-0.10.1
diff --git a/dev-python/hypothesis/hypothesis-6.87.1.ebuild b/dev-python/hypothesis/hypothesis-6.87.1.ebuild
index 0d6df2a9e475..5d255dfeb3df 100644
--- a/dev-python/hypothesis/hypothesis-6.87.1.ebuild
+++ b/dev-python/hypothesis/hypothesis-6.87.1.ebuild
@@ -43,7 +43,6 @@ RDEPEND="
"
BDEPEND="
test? (
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
!!<dev-python/requests-toolbelt-0.10.1
diff --git a/dev-python/hypothesis/hypothesis-6.87.2.ebuild b/dev-python/hypothesis/hypothesis-6.87.2.ebuild
index 0d6df2a9e475..5d255dfeb3df 100644
--- a/dev-python/hypothesis/hypothesis-6.87.2.ebuild
+++ b/dev-python/hypothesis/hypothesis-6.87.2.ebuild
@@ -43,7 +43,6 @@ RDEPEND="
"
BDEPEND="
test? (
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
!!<dev-python/requests-toolbelt-0.10.1
diff --git a/dev-python/hypothesis/hypothesis-6.87.3.ebuild b/dev-python/hypothesis/hypothesis-6.87.3.ebuild
index 0d6df2a9e475..5d255dfeb3df 100644
--- a/dev-python/hypothesis/hypothesis-6.87.3.ebuild
+++ b/dev-python/hypothesis/hypothesis-6.87.3.ebuild
@@ -43,7 +43,6 @@ RDEPEND="
"
BDEPEND="
test? (
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
!!<dev-python/requests-toolbelt-0.10.1
diff --git a/dev-python/hypothesis/hypothesis-6.87.4.ebuild b/dev-python/hypothesis/hypothesis-6.87.4.ebuild
index 0d6df2a9e475..5d255dfeb3df 100644
--- a/dev-python/hypothesis/hypothesis-6.87.4.ebuild
+++ b/dev-python/hypothesis/hypothesis-6.87.4.ebuild
@@ -43,7 +43,6 @@ RDEPEND="
"
BDEPEND="
test? (
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
!!<dev-python/requests-toolbelt-0.10.1
diff --git a/dev-python/hypothesis/hypothesis-6.88.0.ebuild b/dev-python/hypothesis/hypothesis-6.88.0.ebuild
index 0d6df2a9e475..5d255dfeb3df 100644
--- a/dev-python/hypothesis/hypothesis-6.88.0.ebuild
+++ b/dev-python/hypothesis/hypothesis-6.88.0.ebuild
@@ -43,7 +43,6 @@ RDEPEND="
"
BDEPEND="
test? (
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
!!<dev-python/requests-toolbelt-0.10.1
diff --git a/dev-python/hypothesis/hypothesis-6.88.1.ebuild b/dev-python/hypothesis/hypothesis-6.88.1.ebuild
index 0d6df2a9e475..5d255dfeb3df 100644
--- a/dev-python/hypothesis/hypothesis-6.88.1.ebuild
+++ b/dev-python/hypothesis/hypothesis-6.88.1.ebuild
@@ -43,7 +43,6 @@ RDEPEND="
"
BDEPEND="
test? (
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
!!<dev-python/requests-toolbelt-0.10.1