summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-01 13:52:44 -0500
committerTim Harder <radhermit@gentoo.org>2018-03-01 14:34:49 -0500
commit886aa82e1579bf92ba14a12043f4121d7c71b933 (patch)
treed6c9e896a870bb72b888109e87b0b6ba74923004 /dev-python/idna-ssl
parentdev-python/aiohttp: add python project as a maintainer (diff)
downloadgentoo-886aa82e1579bf92ba14a12043f4121d7c71b933.tar.gz
gentoo-886aa82e1579bf92ba14a12043f4121d7c71b933.tar.bz2
gentoo-886aa82e1579bf92ba14a12043f4121d7c71b933.zip
dev-python/idna-ssl: initial import for aiohttp
Diffstat (limited to 'dev-python/idna-ssl')
-rw-r--r--dev-python/idna-ssl/Manifest1
-rw-r--r--dev-python/idna-ssl/idna-ssl-1.0.0.ebuild25
-rw-r--r--dev-python/idna-ssl/metadata.xml12
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/idna-ssl/Manifest b/dev-python/idna-ssl/Manifest
new file mode 100644
index 000000000000..2b15d7ee04ff
--- /dev/null
+++ b/dev-python/idna-ssl/Manifest
@@ -0,0 +1 @@
+DIST idna_ssl-1.0.0.tar.gz 3375 BLAKE2B 28ecee9e271619b7a4f3698aacbdbf0e953ed9b52640818007dc86f34145d8ea000260991d44cfa4cd896b74172b0a32962c3053152558b8d621396df2e248de SHA512 d1f7479cc3edff164bb26deb05af757906ba91241bc668f1b087560087a89f741a0b36e166bfb8142128ceed6008621ab36a2556ed2304ea6374c19982bc663a
diff --git a/dev-python/idna-ssl/idna-ssl-1.0.0.ebuild b/dev-python/idna-ssl/idna-ssl-1.0.0.ebuild
new file mode 100644
index 000000000000..d58e5b28fbc8
--- /dev/null
+++ b/dev-python/idna-ssl/idna-ssl-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Patch ssl.match_hostname for Unicode(idna) domains support"
+HOMEPAGE="https://github.com/aio-libs/idna-ssl https://pypi.python.org/pypi/idna_ssl"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/idna[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
diff --git a/dev-python/idna-ssl/metadata.xml b/dev-python/idna-ssl/metadata.xml
new file mode 100644
index 000000000000..e0f41b17f555
--- /dev/null
+++ b/dev-python/idna-ssl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">idna_ssl</remote-id>
+ <remote-id type="github">aio-libs/idna-ssl</remote-id>
+ </upstream>
+</pkgmetadata>