summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-07 05:29:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-07 06:18:53 +0200
commiteabb115f1271e16ebd7581ec01aad25df5ca87d2 (patch)
treece1b353a6884d940d42aac850b44983317bd3f07 /dev-python/inflect
parentdev-python/Faker: Bump to 18.4.0 (diff)
downloadgentoo-eabb115f1271e16ebd7581ec01aad25df5ca87d2.tar.gz
gentoo-eabb115f1271e16ebd7581ec01aad25df5ca87d2.tar.bz2
gentoo-eabb115f1271e16ebd7581ec01aad25df5ca87d2.zip
dev-python/inflect: Bump to 6.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/inflect')
-rw-r--r--dev-python/inflect/Manifest1
-rw-r--r--dev-python/inflect/inflect-6.0.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/inflect/Manifest b/dev-python/inflect/Manifest
index 9e044580c775..ad645e1c84a7 100644
--- a/dev-python/inflect/Manifest
+++ b/dev-python/inflect/Manifest
@@ -1,2 +1,3 @@
DIST inflect-6.0.2.tar.gz 70830 BLAKE2B 8faa09c53f836429b6e1a2965da3c4315260e1cb3ae7dc40fe226d7f4595e9bd54498167c044f67fed5f79e2997af5425cc13680b9c2b722ffd702095f60b038 SHA512 ddb0439eeffbd21b3293208eb7e89f97fe556a3ba1e88de7e15d1c6bc5a59cdb25a224d7cfec5a010dd384728b15317c1dc752e3a8d4d95dd6eea8224a4f2877
DIST inflect-6.0.3.tar.gz 71294 BLAKE2B ead85b2e17cbf82a1a8cd4a7a0948b43462ab40dc2bd457eadf02c4cbc4e1295c6195da4baafa84cb5d8c6c4df0bcd6439ff2004fc424bc21e786f2e423632f3 SHA512 5bcd40b71301cba7890b31720aca3261224ec909ec3bbe6830e847f040b10daf91ff73cbe8d46c8835aa391a76c88342b268142393c5b96dafee90e668dd59ba
+DIST inflect-6.0.4.tar.gz 71131 BLAKE2B 24ec6f25462594fde4558f7a4269c68d31989ead54c982f3a4382b5f0c192fd5fcac7544413fecef0abaf7c3fe2f9b4a8049fc7dc7d324e4397fb6a81763ef8e SHA512 96aaa74b3e8c5dcc91d81af336af73535826f3cedaa556d6baf540ca54db1a7c1f17a372c240446c0d81697520eab154bad4f0aad6195c6ab8e131ae443d3811
diff --git a/dev-python/inflect/inflect-6.0.4.ebuild b/dev-python/inflect/inflect-6.0.4.ebuild
new file mode 100644
index 000000000000..3f5956338ce9
--- /dev/null
+++ b/dev-python/inflect/inflect-6.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Correctly inflect words and numbers"
+HOMEPAGE="
+ https://pypi.org/project/inflect/
+ https://github.com/jaraco/inflect/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pydantic-1.9.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest