summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-25 06:10:22 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-25 06:14:34 +0100
commit6dc4578b5cee50fbc3ec3c0f403d3137c7d48621 (patch)
treec6a71e2f270b92012f3816086e01da447747d806 /dev-python/ini2toml/ini2toml-0.11.3.ebuild
parentdev-python/pyproject-fmt: Bump to 0.4.1 (diff)
downloadgentoo-6dc4578b5cee50fbc3ec3c0f403d3137c7d48621.tar.gz
gentoo-6dc4578b5cee50fbc3ec3c0f403d3137c7d48621.tar.bz2
gentoo-6dc4578b5cee50fbc3ec3c0f403d3137c7d48621.zip
dev-python/ini2toml: Bump to 0.11.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ini2toml/ini2toml-0.11.3.ebuild')
-rw-r--r--dev-python/ini2toml/ini2toml-0.11.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/ini2toml/ini2toml-0.11.3.ebuild b/dev-python/ini2toml/ini2toml-0.11.3.ebuild
new file mode 100644
index 000000000000..e330aeb75a3d
--- /dev/null
+++ b/dev-python/ini2toml/ini2toml-0.11.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically conversion of .ini/.cfg files to TOML equivalents"
+HOMEPAGE="
+ https://pypi.org/project/ini2toml/
+ https://github.com/abravalheri/ini2toml/
+"
+SRC_URI="
+ https://github.com/abravalheri/ini2toml/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-20.7[${PYTHON_USEDEP}]
+ >=dev-python/tomli-w-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/configupdater[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-fmt-0.4.0[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_IGNORE=(
+ # validate_pyproject is not packaged
+ tests/test_examples.py
+)
+
+src_prepare() {
+ sed -i -e 's:--cov ini2toml --cov-report term-missing::' setup.cfg || die
+ distutils-r1_src_prepare
+}