summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-17 14:00:05 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-17 16:13:10 -0500
commitc67e82ed5038d00fff0769c25480cf817672773a (patch)
tree7cd7c3bf0bee2c345b78bbfa6c39188669ab0794 /dev-python/kafka-python/kafka-python-1.1.1.ebuild
parentdev-perl/Gentoo-App-Pram: Add dev-vcs/git dependency to DEPEND. (diff)
downloadgentoo-c67e82ed5038d00fff0769c25480cf817672773a.tar.gz
gentoo-c67e82ed5038d00fff0769c25480cf817672773a.tar.bz2
gentoo-c67e82ed5038d00fff0769c25480cf817672773a.zip
dev-python/kafka-python: initial ebuild
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/kafka-python/kafka-python-1.1.1.ebuild')
-rw-r--r--dev-python/kafka-python/kafka-python-1.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/kafka-python/kafka-python-1.1.1.ebuild b/dev-python/kafka-python/kafka-python-1.1.1.ebuild
new file mode 100644
index 000000000000..fc2ef436e19f
--- /dev/null
+++ b/dev-python/kafka-python/kafka-python-1.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Kafka protocol support in Python"
+HOMEPAGE="https://github.com/dpkp/kafka-python/ https://pypi.python.org/pypi/kafka-python/"
+SRC_URI="https://github.com/dpkp/kafka-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="snappy test"
+
+RDEPEND="snappy? ( dev-python/snappy[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test || die "tests failed"
+}