summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-31 23:43:23 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-01 00:46:56 +0100
commit283bf202bc0e2db0f892a3afb4b081455b03f8c2 (patch)
tree7d861d87459b6248973a637d68efc2823051d5e9 /dev-python/mongomock/mongomock-4.0.0.ebuild
parentdev-python/pylast: Bump to 4.5.0 (diff)
downloadgentoo-283bf202bc0e2db0f892a3afb4b081455b03f8c2.tar.gz
gentoo-283bf202bc0e2db0f892a3afb4b081455b03f8c2.tar.bz2
gentoo-283bf202bc0e2db0f892a3afb4b081455b03f8c2.zip
dev-python/mongomock: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mongomock/mongomock-4.0.0.ebuild')
-rw-r--r--dev-python/mongomock/mongomock-4.0.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/mongomock/mongomock-4.0.0.ebuild b/dev-python/mongomock/mongomock-4.0.0.ebuild
new file mode 100644
index 000000000000..1763b82a094f
--- /dev/null
+++ b/dev-python/mongomock/mongomock-4.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to help testing Python code that interacts with MongoDB via Pymongo"
+HOMEPAGE="https://github.com/mongomock/mongomock https://pypi.org/project/mongomock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND=">=dev-python/pbr-5.1.1[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pymongo-3.10.1[${PYTHON_USEDEP}]
+ >=dev-python/sentinels-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14.0[${PYTHON_USEDEP}]"
+
+src_test() {
+ # Use NO_LOCAL_MONGO to disable tests that need a MongoDB instance.
+ # TZ=UTC needed for date/time tests to pass
+ TZ=UTC NO_LOCAL_MONGO=1 distutils-r1_src_test
+}
+
+distutils_enable_tests pytest