summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-11-20 11:24:36 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-11-30 15:46:17 +0100
commit86fc237b0882e338f40a319c088f424904a73962 (patch)
tree9464dee5a68073b57a03b2f1a906687ac7418f6e /dev-python/nbval/nbval-0.7.ebuild
parentdev-python/sphinxcontrib-github-alt: new package. (diff)
downloadgentoo-86fc237b0882e338f40a319c088f424904a73962.tar.gz
gentoo-86fc237b0882e338f40a319c088f424904a73962.tar.bz2
gentoo-86fc237b0882e338f40a319c088f424904a73962.zip
dev-python/nbval: new package.
nbval is a py.test plugin to validate Jupyter notebook. The plugin adds functionality to py.test to recognise and collect Jupyter notebooks. The intended purpose of the tests is to determine whether execution of the stored inputs match the stored outputs of the .ipynb file. Whilst also ensuring that the notebooks are running without errors. The tests were designed to ensure that Jupyter notebooks (especially those for reference and documentation), are executing consistently. Each cell is taken as a test, a cell that doesn't reproduce the expected output will fail. Closes: https://bugs.gentoo.org/638208 Closes: https://github.com/gentoo/gentoo/pull/6247 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python/nbval/nbval-0.7.ebuild')
-rw-r--r--dev-python/nbval/nbval-0.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/nbval/nbval-0.7.ebuild b/dev-python/nbval/nbval-0.7.ebuild
new file mode 100644
index 000000000000..fbb65c03f937
--- /dev/null
+++ b/dev-python/nbval/nbval-0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A py.test plugin to validate Jupyter notebooks"
+HOMEPAGE="https://github.com/computationalmodelling/nbval"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ emake test
+}