summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-23 22:46:34 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-23 23:06:48 +0300
commitc6e846bdba92ca8adb57833e7277778823d7b2d4 (patch)
treea22ff5461022927c27dbe0a197fb0c588f640b60 /dev-python/nuitka
parentdev-python/jupyterlab: add 3.4.7 (diff)
downloadgentoo-c6e846bdba92ca8adb57833e7277778823d7b2d4.tar.gz
gentoo-c6e846bdba92ca8adb57833e7277778823d7b2d4.tar.bz2
gentoo-c6e846bdba92ca8adb57833e7277778823d7b2d4.zip
dev-python/nuitka: add 1.0.7
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-1.0.7.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 6d5fc45af232..a00b6c6fab89 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -3,3 +3,4 @@ DIST Nuitka-1.0.2.tar.gz 3893195 BLAKE2B 7d3f154ecb128da34f1495d977ec81bc54dcd95
DIST Nuitka-1.0.3.tar.gz 3894225 BLAKE2B 9e29cfc23c4c1fda50330a6ebfb30fe8a13b18486a87965e9b4daddedd6fb38f6f3c89c606ff63d7a0888bc1c329c593a92d36cfc6b0d2b46a289fa4fd6fc8f5 SHA512 68bab7f431e2469c01c8e3272ea75eff8bffe7a070768759949206109fc4bb035243e3b2511372ec449fe07aff9bc94185f2b3c3301d5e847d091fa340522362
DIST Nuitka-1.0.5.tar.gz 3893771 BLAKE2B 50c4498d13e9fbcf3df9fbf98acd96021dc4c01ef63e1c116ffbbfd878c0b2fc1066470b3f7283652430beefb1f64353b6f6421399654066b9fbd7990f3f4889 SHA512 d8416e8134512c7bb28a0e132942a6832fe7fd8b28bb96b38c2896e7f77fa6d0b1fde71621bb3c909b4877602f77b2e152885245c313097e12accab397cc2a61
DIST Nuitka-1.0.6.tar.gz 3890331 BLAKE2B 4a8240123b61ff7c8ec274e6c318ade2b5057f56b0b766f1a555451f501a194c137696bd51dff23bdd125e1ffa3679f790e3ad50b9c15e85ba5358f56d47b34f SHA512 f431c976b28b80ad10cdbc27c8f0d3321aadace08a104d18089c38d00b80ee96fd3aa051dd50eb668ed57f6aca25e4f918f07d065df00627c139bc34afdcb52c
+DIST Nuitka-1.0.7.tar.gz 3891250 BLAKE2B 6f401de98bae91688d0ceab210d178fdb8d2cb32beeb7dd6925eee7985d0e344e41edcaddbdff8313402625d40dc7236433f52ca71f1100a1168775b9bc3da8b SHA512 29cb7377c976f59d8ea49aedd74798ee11b38b98b597611bd41bd5bef5c2473cd76bb260f764afd277edc4b5bfb8359b995a532ba4814f1d2310fa9c90d1467d
diff --git a/dev-python/nuitka/nuitka-1.0.7.ebuild b/dev-python/nuitka/nuitka-1.0.7.ebuild
new file mode 100644
index 000000000000..5b987e13729d
--- /dev/null
+++ b/dev-python/nuitka/nuitka-1.0.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}