summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-11 18:22:05 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-11 20:20:15 +0000
commitc86f743a40ce02e82f70dd8ef115cb9eee93c0f9 (patch)
tree6bdc92b9fe462d0bd492e7cb0d8a6bad9785b4c4 /dev-python/olefile/olefile-0.44.ebuild
parentsci-libs/gsl: version bump (diff)
downloadgentoo-c86f743a40ce02e82f70dd8ef115cb9eee93c0f9.tar.gz
gentoo-c86f743a40ce02e82f70dd8ef115cb9eee93c0f9.tar.bz2
gentoo-c86f743a40ce02e82f70dd8ef115cb9eee93c0f9.zip
dev-python/olefile: initial import, needed for dev-python/pillow
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/olefile/olefile-0.44.ebuild')
-rw-r--r--dev-python/olefile/olefile-0.44.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/olefile/olefile-0.44.ebuild b/dev-python/olefile/olefile-0.44.ebuild
new file mode 100644
index 000000000000..5770e4e1899a
--- /dev/null
+++ b/dev-python/olefile/olefile-0.44.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to parse, read and write Microsoft OLE2 files"
+HOMEPAGE="https://www.decalage.info/olefile"
+SRC_URI="https://github.com/decalage2/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/. )
+ fi
+
+}