summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-21 12:54:42 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-21 12:56:24 +0100
commit7e33dbbe9f91c5f9f3800546798b4a4a1938c24a (patch)
tree153b2b2ee4ee3c45940ce787f2e575ce0df4331e /dev-python/pyamf/pyamf-0.8.0.ebuild
parentdev-libs/userspace-rcu: Mark ~hppa too. (diff)
downloadgentoo-7e33dbbe9f91c5f9f3800546798b4a4a1938c24a.tar.gz
gentoo-7e33dbbe9f91c5f9f3800546798b4a4a1938c24a.tar.bz2
gentoo-7e33dbbe9f91c5f9f3800546798b4a4a1938c24a.zip
dev-python/pyamf: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyamf/pyamf-0.8.0.ebuild')
-rw-r--r--dev-python/pyamf/pyamf-0.8.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyamf/pyamf-0.8.0.ebuild b/dev-python/pyamf/pyamf-0.8.0.ebuild
new file mode 100644
index 000000000000..25130d89ef9c
--- /dev/null
+++ b/dev-python/pyamf/pyamf-0.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=PyAMF
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Action Message Format (AMF) support for Python"
+HOMEPAGE="https://github.com/hydralabs/pyamf https://pypi.python.org/pypi/PyAMF"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/defusedxml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "PyAMF optionally integrates with several third-party libraries"
+ elog "and web frameworks. See the README or the Optional Extras section at"
+ elog "https://github.com/hydralabs/pyamf/blob/master/doc/install.rst"
+ fi
+}