summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-10-21 01:33:56 +0200
committerMichał Górny <mgorny@gentoo.org>2017-10-21 01:44:08 +0200
commitc3e8a0f2587f714081e54509097d905be1baa9dd (patch)
tree815d69e6805cfb3d1c910d72f5557a3cc423aae6 /dev-python/pyblake2
parentdev-python/pyblake2: New package (diff)
downloadgentoo-c3e8a0f2587f714081e54509097d905be1baa9dd.tar.gz
gentoo-c3e8a0f2587f714081e54509097d905be1baa9dd.tar.bz2
gentoo-c3e8a0f2587f714081e54509097d905be1baa9dd.zip
dev-python/pyblake2: Default to faster REGS variant
Diffstat (limited to 'dev-python/pyblake2')
-rw-r--r--dev-python/pyblake2/pyblake2-0.9.3.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-python/pyblake2/pyblake2-0.9.3.ebuild b/dev-python/pyblake2/pyblake2-0.9.3.ebuild
index 37d5457bb6d5..79f80083bcb7 100644
--- a/dev-python/pyblake2/pyblake2-0.9.3.ebuild
+++ b/dev-python/pyblake2/pyblake2-0.9.3.ebuild
@@ -15,6 +15,17 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+python_prepare_all() {
+ local impl=REGS
+ # note: SSE2 is 2.5x slower than pure REGS...
+ # TODO: test other variants on some capable hardware
+
+ # uncomment the implementation of choice
+ sed -i -e "/BLAKE2_COMPRESS_${impl}/s:^#::" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
python_test() {
"${EPYTHON}" test/test.py || die "Tests fail with ${EPYTHON}"
}