summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-13 07:56:58 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-13 08:19:17 +0100
commit71f4d670cde1dd13173f61a223057b28cc23a0be (patch)
tree45394d4810efa737e11abc442b057af531d2f7f3 /dev-python/pychm
parentdev-util/lldb: Update upstream CMake var names (diff)
downloadgentoo-71f4d670cde1dd13173f61a223057b28cc23a0be.tar.gz
gentoo-71f4d670cde1dd13173f61a223057b28cc23a0be.tar.bz2
gentoo-71f4d670cde1dd13173f61a223057b28cc23a0be.zip
dev-python/pychm: Bump to 0.8.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pychm')
-rw-r--r--dev-python/pychm/Manifest1
-rw-r--r--dev-python/pychm/pychm-0.8.6.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pychm/Manifest b/dev-python/pychm/Manifest
index 99c807879f19..6609951b341d 100644
--- a/dev-python/pychm/Manifest
+++ b/dev-python/pychm/Manifest
@@ -1,2 +1,3 @@
DIST pychm-0.8.4.tar.gz 28803 BLAKE2B c6b66c83b1bd5b20280cb60636ccf2780f665fd589b107542c887fc791642f780701b84c8863883e02496c626b92552e3bbfdacd025723fccdb7947de62ada61 SHA512 0c0c107e59ea9f5fef97a0c2869349b5e90fc9eb7a37c35e8a929eaf764c7abe5a06a389340a912b9ba2f71172f3c94a78da016707bb201bbd07bdc3feddfe0d
DIST pychm-0.8.5.gh.tar.gz 23539 BLAKE2B 4671ccca56153ee493f239de46a01c9e878448f46ecb7e1a39156457562d7f7ac951007e04bd534ea26455da68607eab9b2e2266eed71a7b14c90f103888887e SHA512 3f6b175710880fd4e45c4407af06bec580839517727ee0f5f706747c78be727171f7f8ad2d8fa9add0065825556c3a5d48cc1a6016705f34569350c495f5710d
+DIST pychm-0.8.6.gh.tar.gz 23803 BLAKE2B fdf3c37eead60455fd5bde1638a010f2788074752f98c32cf4b3431b4a87b8893c23a9fa29995352b35b41f628b7026fdbfa6ff20b75e8a6efdf75fc2da3f67d SHA512 cc1b254b6c58aba038171ad9db1eea3212094d7fb9386b22ada67381d702b388e6a1dde0317b5724587ee135d2695c546a7c2d65af7091dafeb394647597b0ae
diff --git a/dev-python/pychm/pychm-0.8.6.ebuild b/dev-python/pychm/pychm-0.8.6.ebuild
new file mode 100644
index 000000000000..5d77dcd07ccc
--- /dev/null
+++ b/dev-python/pychm/pychm-0.8.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the chmlib library"
+HOMEPAGE="https://github.com/dottedmag/pychm"
+SRC_URI="https://github.com/dottedmag/pychm/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-libs/chmlib"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest