summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-07-03 14:46:48 +0200
committerSebastian Pipping <sping@gentoo.org>2022-07-03 15:10:28 +0200
commit5462192952df93e30e13123e8187bbe7a0046a41 (patch)
treef3320f174d920183d9734166e2a83e062701c7a9 /dev-python/pycxx
parentapp-portage/iwdevtools: stabilize 0.11.2 for ALLARCHES (diff)
downloadgentoo-5462192952df93e30e13123e8187bbe7a0046a41.tar.gz
gentoo-5462192952df93e30e13123e8187bbe7a0046a41.tar.bz2
gentoo-5462192952df93e30e13123e8187bbe7a0046a41.zip
dev-python/pycxx: Python 3.10 + EAPI 8
Closes: https://bugs.gentoo.org/835726 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/pycxx-7.1.5-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pycxx/pycxx-7.1.5-r1.ebuild b/dev-python/pycxx/pycxx-7.1.5-r1.ebuild
new file mode 100644
index 000000000000..20eddf8c6d66
--- /dev/null
+++ b/dev-python/pycxx/pycxx-7.1.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="doc examples"
+
+python_prepare_all() {
+ # Without this, pysvn fails.
+ # Src/Python3/cxxextensions.c: No such file or directory
+ sed -e "/^#include/s:Src/::" -i Src/*.{c,cxx} || die "sed failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r Demo/Python{2,3}/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}