summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-01-26 13:09:13 -0800
committerZac Medico <zmedico@gentoo.org>2020-01-26 13:21:29 -0800
commitdb696bbf1db08f6a1b1cedf8d168a966be92a17c (patch)
tree9412d024bee62367425f4cd4bdcb7b30f1f568cf /dev-python/pyghmi
parentgames-strategy/lgeneral: Remove old 1.3.1-r2 (diff)
downloadgentoo-db696bbf1db08f6a1b1cedf8d168a966be92a17c.tar.gz
gentoo-db696bbf1db08f6a1b1cedf8d168a966be92a17c.tar.bz2
gentoo-db696bbf1db08f6a1b1cedf8d168a966be92a17c.zip
dev-python/pyghmi: 1.0.22-r1 revbump
Remove dev-python/hacking test dep. Reported-by: Matthew Thode <prometheanfire@gentoo.org> Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/pyghmi-1.0.22-r1.ebuild (renamed from dev-python/pyghmi/pyghmi-1.0.22.ebuild)11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/pyghmi/pyghmi-1.0.22.ebuild b/dev-python/pyghmi/pyghmi-1.0.22-r1.ebuild
index 39164e26ed17..d825c3250b25 100644
--- a/dev-python/pyghmi/pyghmi-1.0.22.ebuild
+++ b/dev-python/pyghmi/pyghmi-1.0.22-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
@@ -16,8 +16,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-python/pbr[${PYTHON_USEDEP}]
- >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pbr[${PYTHON_USEDEP}]"
#636824 older versions of cli_helpers break the build
DEPEND="${RDEPEND}
!<dev-python/cli_helpers-1.0.0
@@ -25,7 +24,6 @@ DEPEND="${RDEPEND}
test? (
>=dev-python/coverage-3.6[${PYTHON_USEDEP}]
>=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
- >=dev-python/hacking-0.5[${PYTHON_USEDEP}]
>=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
>=dev-python/os-testr-0.8.0[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
@@ -35,6 +33,11 @@ DEPEND="${RDEPEND}
>=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
)"
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed '/^pycrypto>=2\.6$/d' -i requirements.txt || die
+}
+
python_test() {
esetup.py testr --coverage || die "Tests failed under ${EPYTHON}"
}