summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-11 15:23:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-11 15:31:52 +0100
commit9fd2cab6eabf8b9b8309ea55b51d4ee27c5e0536 (patch)
treeb80c075cb8c3ad98553bd324a928fb73ab082aca /dev-python/pygit2
parentdev-util/stripe-mock: Bump to 0.145.0 (diff)
downloadgentoo-9fd2cab6eabf8b9b8309ea55b51d4ee27c5e0536.tar.gz
gentoo-9fd2cab6eabf8b9b8309ea55b51d4ee27c5e0536.tar.bz2
gentoo-9fd2cab6eabf8b9b8309ea55b51d4ee27c5e0536.zip
dev-python/pygit2: Bump to 1.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest1
-rw-r--r--dev-python/pygit2/pygit2-1.11.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index a1049cd54091..9a3a580f670d 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1,2 +1,3 @@
DIST pygit2-1.10.1.gh.tar.gz 752254 BLAKE2B b0f09eb65be19e9bb0e21afab4613478e1ad516f2cdd10c01328b73233e4e7f3a33d2c90c5ccb35a55050b18e6bf1e1dadb330457a78d0fed9d75da5a4082588 SHA512 d545b5919b6c1ef5411a20acc7463a7ff934852bef209c7254b33365ccb6e127f136537745088be387a07a70e99d2a12466570a515fcb9410216a34a565e7ea9
DIST pygit2-1.11.0.gh.tar.gz 757139 BLAKE2B aef7dd1e9dfe8961be9e34c63ab07b13f9cd3affde2b28cc97a2c227c121662f7464ba1af741a5a06a3ac153531c4158699ffb94b393bcf954248afa10088ede SHA512 2bde656d0f6565a827cb2d090a4e3211d838a6822954cbaf01db67976e6959bbb21a24b4671398f59f3793923c5b6bb484e62b6b8af28998b06cfe3758165668
+DIST pygit2-1.11.1.gh.tar.gz 757247 BLAKE2B 0cd5cf276e1bec375635905ca072b021e29821f9ebc878dc1ae92d0c0a0cbca00481ed3501550161827e4d6e9e018edf165a2e59eb0cbd0ec0004d6c1c10f7eb SHA512 c831afb30ec4c0c4972687f28196915ccb428bf2e242eed17ff50bf700f06db59dcec254e1104bea9a335bc7955f36143085395d8463a750f4492e8c701b2061
diff --git a/dev-python/pygit2/pygit2-1.11.1.ebuild b/dev-python/pygit2/pygit2-1.11.1.ebuild
new file mode 100644
index 000000000000..47951e5eef7a
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.11.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="
+ https://github.com/libgit2/pygit2/
+ https://pypi.org/project/pygit2/
+"
+SRC_URI="
+ https://github.com/libgit2/pygit2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ =dev-libs/libgit2-1.5*:=
+"
+BDEPEND="
+ >=dev-python/cffi-1.9.1:=[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditionally prevent it from using network
+ sed -i -e '/has_network/s:True:False:' test/utils.py || die
+}
+
+src_test() {
+ rm -r pygit2 || die
+ distutils-r1_src_test
+}