summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-09 07:59:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-09 08:30:57 +0200
commitfdb0cd13d0177d454cc470a4d023e9df1164eb19 (patch)
tree8ffc77ecc542fc19ae75a7cfbe24a9bb542f6398 /dev-python/pyglet
parentdev-python/pyglet: Remove old (diff)
downloadgentoo-fdb0cd13d0177d454cc470a4d023e9df1164eb19.tar.gz
gentoo-fdb0cd13d0177d454cc470a4d023e9df1164eb19.tar.bz2
gentoo-fdb0cd13d0177d454cc470a4d023e9df1164eb19.zip
dev-python/pyglet: Bump to 2.0.18
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyglet')
-rw-r--r--dev-python/pyglet/Manifest1
-rw-r--r--dev-python/pyglet/pyglet-2.0.18.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/pyglet/Manifest b/dev-python/pyglet/Manifest
index d4ef36086879..c04dfccb1053 100644
--- a/dev-python/pyglet/Manifest
+++ b/dev-python/pyglet/Manifest
@@ -1,2 +1,3 @@
DIST pyglet-2.0.15.gh.tar.gz 6426555 BLAKE2B 8066ac7c3acd613a6fe02403ec5c88822744d6f7ab5e0043ca01443ab94249be7e542bc97f5354286bd3f5675c1c2e4d108ab474d659efe2905b9892e44ece0c SHA512 8b85264a9f13505f86cef694ebdf1e1ff707980b6ec9d205a1c1ef639b2de0c837926476f8a26b33b7ad8a0cd7d9acfefdd0707bace1734db4185a48f01305d4
DIST pyglet-2.0.17.gh.tar.gz 6499366 BLAKE2B 2113cc99459a543f5ae9612b89d214e99961e30e26ca367b6054b255173375187316d706a13409a160f1f57b4b56029c82ebb74f8722897a8d73e0aa23c88793 SHA512 25657e337df995059bcb7de18c14d151ea5a675e98b6c4ac6524b4cdbee1f44f280d09d15c86bada9f7309de36eb5dcd91ef177d96cbbe8f06c8ef9856838ce3
+DIST pyglet-2.0.18.gh.tar.gz 6505764 BLAKE2B 1eff94cdce597d8a1878d7999ad3d367dcfd03c7ac37af4d299357528ee79f12ece5b896fb0bb3584cf5145e7239a76a9b7cb370e977f9d09b832ff88d230236 SHA512 16c599f99d6b80214f04d7113af78dbec0f491dbe42febc4590cc80a4bbefbd3f1431fe1d6b1f87f48396d367750f7993e4b08b5e329b5d08b93c050c05c6bc6
diff --git a/dev-python/pyglet/pyglet-2.0.18.ebuild b/dev-python/pyglet/pyglet-2.0.18.ebuild
new file mode 100644
index 000000000000..5993f74d2714
--- /dev/null
+++ b/dev-python/pyglet/pyglet-2.0.18.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="Cross-platform windowing and multimedia library for Python"
+HOMEPAGE="
+ https://pyglet.org/
+ https://github.com/pyglet/pyglet/
+ https://pypi.org/project/pyglet/
+"
+SRC_URI="https://github.com/pyglet/pyglet/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples image +sound"
+
+RDEPEND="
+ virtual/glu
+ virtual/opengl
+ image? (
+ || (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-libs/gtk+:2
+ )
+ )
+ sound? (
+ || (
+ media-libs/libpulse
+ media-libs/openal
+ )
+ )
+"
+# ffmpeg? ( media-libs/avbin-bin )
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/fontconfig
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ xdg_environment_reset
+
+ local EPYTEST_DESELECT=(
+ # lacking device/server permissions
+ tests/unit/media/test_listener.py::test_openal_listener
+ tests/unit/media/test_listener.py::test_pulse_listener
+ # fragile to system load
+ tests/unit/media/test_player.py::PlayerTestCase::test_pause_resume
+ tests/unit/test_clock_freq.py::test_elapsed_time_between_tick
+ )
+
+ # Specify path to avoid running interactive tests
+ # We could add in integration tests, but they're slow
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest tests/unit || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}