summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-15 18:02:56 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-16 13:33:34 +0100
commit73b650cc29c8819f87fd7a78ebec980e21a0d7bd (patch)
tree7b467bc397059d8a5fa7cc98667568303747bf27 /dev-python/pypy3
parentdev-python/pypy: Fix mtimes between generated and source files (diff)
downloadgentoo-73b650cc29c8819f87fd7a78ebec980e21a0d7bd.tar.gz
gentoo-73b650cc29c8819f87fd7a78ebec980e21a0d7bd.tar.bz2
gentoo-73b650cc29c8819f87fd7a78ebec980e21a0d7bd.zip
dev-python/pypy3: Fix mtimes between generated and source files
Ensure to preserve file mtimes while copying them from the source tree to the installation image. This ensures that the generated files are newer than source files, and that PyPy does not attempt to rewrite them at runtime.
Diffstat (limited to 'dev-python/pypy3')
-rw-r--r--dev-python/pypy3/pypy3-5.9.0-r1.ebuild (renamed from dev-python/pypy3/pypy3-5.9.0.ebuild)2
-rw-r--r--dev-python/pypy3/pypy3-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/pypy3/pypy3-5.9.0.ebuild b/dev-python/pypy3/pypy3-5.9.0-r1.ebuild
index 1fe12fc2c523..a1892572aacb 100644
--- a/dev-python/pypy3/pypy3-5.9.0.ebuild
+++ b/dev-python/pypy3/pypy3-5.9.0-r1.ebuild
@@ -210,6 +210,8 @@ src_install() {
doexe pypy3-c libpypy3-c.so
pax-mark m "${ED%/}${dest}/pypy3-c" "${ED%/}${dest}/libpypy3-c.so"
insinto "${dest}"
+ # preserve mtimes to avoid obsoleting caches
+ insopts -p
doins -r include lib_pypy lib-python
dosym ../$(get_libdir)/pypy3/pypy3-c /usr/bin/pypy3
dodoc README.rst
diff --git a/dev-python/pypy3/pypy3-9999.ebuild b/dev-python/pypy3/pypy3-9999.ebuild
index 1369c84d3fc9..ff2a3ff800ed 100644
--- a/dev-python/pypy3/pypy3-9999.ebuild
+++ b/dev-python/pypy3/pypy3-9999.ebuild
@@ -237,6 +237,8 @@ src_install() {
doexe pypy3-c libpypy3-c.so
pax-mark m "${ED%/}${dest}/pypy3-c" "${ED%/}${dest}/libpypy3-c.so"
insinto "${dest}"
+ # preserve mtimes to avoid obsoleting caches
+ insopts -p
doins -r include lib_pypy lib-python
dosym ../$(get_libdir)/pypy3/pypy3-c /usr/bin/pypy3
dodoc README.rst