summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-29 07:52:28 +0000
committerSam James <sam@gentoo.org>2021-12-29 07:58:12 +0000
commite7b8a1b72eecc5ce57c6ff3eaeb83b5b1dd3545d (patch)
tree7631f9afcb60f1df39dbc735cb1e66f0e714e429 /dev-python/pytables
parentgames-misc/fortune-mod: add 3.12.0 (diff)
downloadgentoo-e7b8a1b72eecc5ce57c6ff3eaeb83b5b1dd3545d.tar.gz
gentoo-e7b8a1b72eecc5ce57c6ff3eaeb83b5b1dd3545d.tar.bz2
gentoo-e7b8a1b72eecc5ce57c6ff3eaeb83b5b1dd3545d.zip
dev-python/pytables: fix installation, hdf5 dep
Should work with newer hdf5 now. Closes: https://bugs.gentoo.org/830209 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pytables')
-rw-r--r--dev-python/pytables/pytables-3.7.0-r1.ebuild (renamed from dev-python/pytables/pytables-3.7.0.ebuild)6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/pytables/pytables-3.7.0.ebuild b/dev-python/pytables/pytables-3.7.0-r1.ebuild
index 48edb62f3560..bbd5389892f6 100644
--- a/dev-python/pytables/pytables-3.7.0.ebuild
+++ b/dev-python/pytables/pytables-3.7.0-r1.ebuild
@@ -22,7 +22,6 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~a
IUSE="doc examples test"
RESTRICT="!test? ( test )"
-# See https://github.com/PyTables/PyTables/issues/912 for hdf5 upper bound
DEPEND="
app-arch/bzip2:0=
app-arch/lz4:0=
@@ -30,7 +29,7 @@ DEPEND="
>=dev-libs/c-blosc-1.11.1:0=
dev-libs/lzo:2=
>=dev-python/numpy-1.8.1[${PYTHON_USEDEP}]
- <sci-libs/hdf5-1.12:=
+ >=sci-libs/hdf5-1.10:=
"
RDEPEND="${DEPEND}
>=dev-python/numexpr-2.5.2[${PYTHON_USEDEP}]
@@ -44,7 +43,7 @@ BDEPEND="
)
"
-DOCS=( RELEASE_NOTES.txt THANKS )
+DOCS=( doc/source/release_notes.rst THANKS )
python_prepare_all() {
export {BLOSC,BZIP2,LZO,HDF5}_DIR="${ESYSROOT}"/usr
@@ -72,6 +71,7 @@ python_install_all() {
if use doc; then
DOCS+=( doc/scripts )
fi
+
distutils-r1_python_install_all
if use examples; then