summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-05-28 12:27:48 -0400
committerMike Gilbert <floppym@gentoo.org>2017-05-28 13:29:34 -0400
commitd1f3e2c6f7958611ab8b352befba2c0ee2517509 (patch)
tree4a94534b087fe398c1acc5ede6ad44c87c76ea6a /dev-python/pytest
parentkde-plasma/plasma-workspace: Drop old (diff)
downloadgentoo-d1f3e2c6f7958611ab8b352befba2c0ee2517509.tar.gz
gentoo-d1f3e2c6f7958611ab8b352befba2c0ee2517509.tar.bz2
gentoo-d1f3e2c6f7958611ab8b352befba2c0ee2517509.zip
dev-python/pytest: remove live ebuild
Package-Manager: Portage-2.3.6_p1, Repoman-2.3.2_p69
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/pytest-9999.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/pytest/pytest-9999.ebuild b/dev-python/pytest/pytest-9999.ebuild
deleted file mode 100644
index ff70a75459a1..000000000000
--- a/dev-python/pytest/pytest-9999.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ https://pypi.python.org/pypi/pytest"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/pytest-dev/pytest.git"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE="doc test"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.4.29"
-RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
-
-# dev-python/pluggy
-# https://github.com/hpk42/pluggy
-# See https://github.com/pytest-dev/pytest/issues/944
-# for why not now
-
-#pexpect dep based on https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pexpect[${PYTHON_USEDEP}] )
- doc? (
- >=dev-python/sphinx-1.2.3[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/regendoc[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # Disable versioning of py.test script to avoid collision with
- # versioning performed by the eclass.
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
- grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
-
- # Prevent un-needed d'loading
- sed -e "s/'sphinx.ext.intersphinx', //" -i doc/en/conf.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- mkdir doc/en/.build || die
- emake -C doc/en html
- fi
-}
-
-python_test() {
- # test_nose.py not written to suit py3.2 in pypy3
- if [[ "${EPYTHON}" == pypy3 ]]; then
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py -x -v \
- --ignore=testing/BUILD_nose.py \
- || die "tests failed with ${EPYTHON}"
- else
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py -x -v --runpytest=subprocess \
- || die "tests failed with ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/en/_build/html/. )
- distutils-r1_python_install_all
-}