summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-28 11:06:24 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-28 11:09:24 +0200
commit989d3afa60f33f990a777c254afe4dfe4e248f3a (patch)
tree42fa0e35dc05a40b8e0dbfc37f21420b15566108 /dev-python/python-distutils-extra/python-distutils-extra-2.44-r1.ebuild
parentnet-libs/libtorrent-rasterbar: remove py27 (diff)
downloadgentoo-989d3afa60f33f990a777c254afe4dfe4e248f3a.tar.gz
gentoo-989d3afa60f33f990a777c254afe4dfe4e248f3a.tar.bz2
gentoo-989d3afa60f33f990a777c254afe4dfe4e248f3a.zip
dev-python/python-distutils-extra: Fix --skip-build support
Closes: https://bugs.gentoo.org/718394 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-distutils-extra/python-distutils-extra-2.44-r1.ebuild')
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.44-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.44-r1.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.44-r1.ebuild
new file mode 100644
index 000000000000..459bb16f3d89
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.44-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
+HOMEPAGE="
+ https://salsa.debian.org/python-team/modules/python-distutils-extra
+ https://launchpad.net/python-distutils-extra"
+SRC_URI="
+ https://salsa.debian.org/python-team/modules/python-distutils-extra/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DOCS=( doc/{README,FAQ} )
+
+BDEPEND="
+ test? (
+ dev-libs/gobject-introspection
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/python-distutils-extra-2.44-test.patch
+ "${FILESDIR}"/python-distutils-extra-2.44-skip-build.patch
+)
+
+python_test() {
+ unset PYTHONDONTWRITEBYTECODE
+ "${EPYTHON}" test/auto.py -v || die "Tests fail with ${EPYTHON}"
+}