summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-17 04:47:17 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-17 04:47:17 +0200
commit4747e394dceae0b85e1a64ab82096f1ea97c1970 (patch)
tree3758d661f21771931a726c073666f62560329c3d /dev-python/quantities
parentdev-python/pbs-installer: Bump to 2024.10.16 (diff)
downloadgentoo-4747e394dceae0b85e1a64ab82096f1ea97c1970.tar.gz
gentoo-4747e394dceae0b85e1a64ab82096f1ea97c1970.tar.bz2
gentoo-4747e394dceae0b85e1a64ab82096f1ea97c1970.zip
dev-python/quantities: Bump to 0.16.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/quantities')
-rw-r--r--dev-python/quantities/Manifest1
-rw-r--r--dev-python/quantities/quantities-0.16.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/quantities/Manifest b/dev-python/quantities/Manifest
index fe161fbff38d..a68b64fbe98b 100644
--- a/dev-python/quantities/Manifest
+++ b/dev-python/quantities/Manifest
@@ -1 +1,2 @@
DIST python-quantities-0.16.0.gh.tar.gz 92228 BLAKE2B 2570b50a983cf1e84fc6df0590a2de251f671d15af06191c4fbf673c7bb75ec419e04f7bcc1a1730f87ed2269b40d707aa6a1103d1238421c19b939f2bbc7f2b SHA512 592001add7201868844197e67ac3a200d4a82c11f02c0d2ce4f007bda5b8c66c29c0f30563da7fd214c3aede4564590b1de9e29b2e9dac0a77a1db0b410e750d
+DIST python-quantities-0.16.1.gh.tar.gz 92552 BLAKE2B b2a1b2b4945aa89f2b75f7e848ba01b0fd9180386efdbcfe2f257eec9cf1600143644d18b5cdf4ccc7442c5982036ac9b48cba2a25a3f208f809dad9cb3de795 SHA512 cba89192ad82b811bb3665cf0eaaaa933e7c5c7a0a02a4ef4895f3b0febadf7aafc71d42dc7c616cdac479fcb2703e25fa37a3e9e5ba06775faf7c1f04a3f884
diff --git a/dev-python/quantities/quantities-0.16.1.ebuild b/dev-python/quantities/quantities-0.16.1.ebuild
new file mode 100644
index 000000000000..e30d4a40296f
--- /dev/null
+++ b/dev-python/quantities/quantities-0.16.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P="python-quantities-${PV}"
+DESCRIPTION="Support for physical quantities with units, based on numpy"
+HOMEPAGE="
+ https://github.com/python-quantities/python-quantities/
+ https://pypi.org/project/quantities/
+"
+SRC_URI="
+ https://github.com/python-quantities/python-quantities/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.20[$PYTHON_USEDEP]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ epytest --pyargs quantities.tests
+}