summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-30 05:52:32 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-30 05:52:32 +0200
commitb250e8d3f3856214d6003a1ab2204af73cbe6ca7 (patch)
treeee0241f7462bdc3e864d91489e903d0989832d31 /dev-python/recurring-ical-events
parentdev-python/recurring-ical-events: Remove old (diff)
downloadgentoo-b250e8d3f3856214d6003a1ab2204af73cbe6ca7.tar.gz
gentoo-b250e8d3f3856214d6003a1ab2204af73cbe6ca7.tar.bz2
gentoo-b250e8d3f3856214d6003a1ab2204af73cbe6ca7.zip
dev-python/recurring-ical-events: Bump to 3.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/recurring-ical-events')
-rw-r--r--dev-python/recurring-ical-events/Manifest1
-rw-r--r--dev-python/recurring-ical-events/recurring-ical-events-3.3.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/recurring-ical-events/Manifest b/dev-python/recurring-ical-events/Manifest
index 13ce1e7c132c..aa6e03b4eeba 100644
--- a/dev-python/recurring-ical-events/Manifest
+++ b/dev-python/recurring-ical-events/Manifest
@@ -1 +1,2 @@
DIST python-recurring-ical-events-3.3.0.gh.tar.gz 472075 BLAKE2B 70f531550a8d766e027fb9416883880385731c8b72a4115e2311024bfc4eac8fc7e8b06dc079309430e8d9da6d725c3e2efce8ce7e1ae93ca7f1d1cd288ff41b SHA512 d414d2b035c80d46fa7ea63c9df995edf632841b4f2bd9072d9004a2aaf8a9468de276330c5f939f172a93121577bfd1402606b9fab525af9aa662cd49c16501
+DIST python-recurring-ical-events-3.3.1.gh.tar.gz 478584 BLAKE2B 79728b5a1aed1495e468cf0ad86ee1a130b6f5100576ecae93ad2d278ae998fb4a89825c046800c6064eda674499bd5ca2cc29a2031c41486f23155de6d67522 SHA512 dd2b4de334ef48efaf201b833cf21cc25be3a39f9c06466a6a25a0f8402d01d7262c4030ba0878d74efb6b3011bdcf5c7fcea5b114ab908c7fa30a37c3ba6f88
diff --git a/dev-python/recurring-ical-events/recurring-ical-events-3.3.1.ebuild b/dev-python/recurring-ical-events/recurring-ical-events-3.3.1.ebuild
new file mode 100644
index 000000000000..6c85248725e5
--- /dev/null
+++ b/dev-python/recurring-ical-events/recurring-ical-events-3.3.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Repeat ICalendar events by RRULE, RDATE and EXDATE"
+HOMEPAGE="
+ https://github.com/niccokunzmann/python-recurring-ical-events/
+ https://pypi.org/project/recurring-ical-events/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/python-recurring-ical-events/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/icalendar-7[${PYTHON_USEDEP}]
+ >=dev-python/icalendar-5.0.9[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ <dev-python/x-wr-timezone-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/x-wr-timezone-0.0.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/icalendar-6[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2023.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)