summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 21:59:04 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 22:26:25 -0600
commit668a6d93fcd19e760ff8dbafe4c2188c66d5fc9d (patch)
tree07d91c82d7444074de413536454ac9e4020ba7f5 /dev-python/requests-mock/requests-mock-1.2.0.ebuild
parentdev-python/python-swiftclient: bup (diff)
downloadgentoo-668a6d93fcd19e760ff8dbafe4c2188c66d5fc9d.tar.gz
gentoo-668a6d93fcd19e760ff8dbafe4c2188c66d5fc9d.tar.bz2
gentoo-668a6d93fcd19e760ff8dbafe4c2188c66d5fc9d.zip
dev-python/requests-mock: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/requests-mock/requests-mock-1.2.0.ebuild')
-rw-r--r--dev-python/requests-mock/requests-mock-1.2.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/requests-mock/requests-mock-1.2.0.ebuild b/dev-python/requests-mock/requests-mock-1.2.0.ebuild
new file mode 100644
index 000000000000..b2a20c177f1e
--- /dev/null
+++ b/dev-python/requests-mock/requests-mock-1.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock out responses from the requests package"
+HOMEPAGE="https://github.com/jamielennox/requests-mock"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}