summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-01-18 19:10:58 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-01-18 19:10:58 +0200
commitd61e71df317c86c4bfd50b3afd8415244b8060bf (patch)
tree03c4defc92ce9fdc3509880b837c0999f09b21ff /dev-python/rope
parentapp-metrics/portage-exporter: drop 0_p20230307, 0.0.1 (diff)
downloadgentoo-d61e71df317c86c4bfd50b3afd8415244b8060bf.tar.gz
gentoo-d61e71df317c86c4bfd50b3afd8415244b8060bf.tar.bz2
gentoo-d61e71df317c86c4bfd50b3afd8415244b8060bf.zip
dev-python/rope: add 1.12.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/rope-1.12.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index 52985384ea98..8ee727dafb08 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1 +1,2 @@
DIST rope-1.11.0.tar.gz 287210 BLAKE2B 64aebaf2a52f84d6e92ba0ccbaf5421b46a52de92675c03922167e2d363d5916675856795b0adaa70d54d4e8249870348ee002648244537dc1acb123fc8c6350 SHA512 e5c382325a900c1b5870aae0b7ef60528da6c73a27834b557f5245e6a6bf3412451c730cac0d5fb12f1a668dd7a8d8d0c814826babce59eb00198cd6706c016d
+DIST rope-1.12.0.tar.gz 288737 BLAKE2B d6ad6b549969f52c8a4a84bedd3c652e683157ce79a42677b3b475b7001e802d68c12c91d8d915eb07f562ce84d42d046d83852404aab9ee309c616640364e77 SHA512 36b948b0bb212faeb77fd93bfc0b8586c41ca260ec01cddafe4599a28630b16d74c7eeacc82755a7d9ff7d2497e2d4fa2bfddd270c3f6194c50430f884c1e6e8
diff --git a/dev-python/rope/rope-1.12.0.ebuild b/dev-python/rope/rope-1.12.0.ebuild
new file mode 100644
index 000000000000..447d0578b5f5
--- /dev/null
+++ b/dev-python/rope/rope-1.12.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytoolconfig-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # our venv style confuses this comparison
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_source_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_compiled
+)