summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-07-23 10:43:36 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-07-25 19:27:48 +0200
commit9e37d7271496b9740d37fce7a3785de1a40d1173 (patch)
tree7366d0053d3c95c12af68908d03549b77f4640e0 /dev-python/s3fs
parentdev-python/globre: version bump. (diff)
downloadgentoo-9e37d7271496b9740d37fce7a3785de1a40d1173.tar.gz
gentoo-9e37d7271496b9740d37fce7a3785de1a40d1173.tar.bz2
gentoo-9e37d7271496b9740d37fce7a3785de1a40d1173.zip
dev-python/s3fs: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/s3fs')
-rw-r--r--dev-python/s3fs/Manifest1
-rw-r--r--dev-python/s3fs/s3fs-0.1.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/s3fs/Manifest b/dev-python/s3fs/Manifest
index 770ce8b9f8a6..7597b9ac3e08 100644
--- a/dev-python/s3fs/Manifest
+++ b/dev-python/s3fs/Manifest
@@ -1 +1,2 @@
DIST s3fs-0.1.2.tar.gz 24574 BLAKE2B 2b62202d8ceec078ca93c6da895a81648c83e0fbd764dbcf4cb1a0ce2c2a8a7cd16a3cc5162d095ec1272b52c9da743d8c8d21f5b351e6a4f3d63cbd77d9b43c SHA512 52be23ccb2dd8c63675287895d00fda94adf010ac878ca12e5c8eefa25c7076c000b53bb4d2bb7886550cdd0d226cdf51aeee12f2ad7bac46537f190ba72ec2f
+DIST s3fs-0.1.5.tar.gz 27215 BLAKE2B 84f059eafe14a4faf8945c355763d31a49f38c3ae6cb05170dbff0e7ad435f9ea79617fc538d237b565d20a0b11603ea44d9e71339fd40c1ad16ad0af903bbd5 SHA512 5285da6d82de1e68c4cb0fad5a93eeb59fdffba663691d79cafd1b428b60e17fa21e0ff3a50df701cad7f351017cdc538954b0516782e5ddcf6c3d5910f71144
diff --git a/dev-python/s3fs/s3fs-0.1.5.ebuild b/dev-python/s3fs/s3fs-0.1.5.ebuild
new file mode 100644
index 000000000000..ffec642e474f
--- /dev/null
+++ b/dev-python/s3fs/s3fs-0.1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic file interface to S3"
+HOMEPAGE="http://s3fs.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die
+}