summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-04 06:09:36 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-04 06:48:02 +0100
commit08b13b4312ba3383d26c1b2df6ac512e23f1aa2e (patch)
tree4562189591567edae0e87a1b8e1c4fee08aec670 /dev-python/sexpdata
parentdev-python/pylint: Bump to 2.16.3 (diff)
downloadgentoo-08b13b4312ba3383d26c1b2df6ac512e23f1aa2e.tar.gz
gentoo-08b13b4312ba3383d26c1b2df6ac512e23f1aa2e.tar.bz2
gentoo-08b13b4312ba3383d26c1b2df6ac512e23f1aa2e.zip
dev-python/sexpdata: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sexpdata')
-rw-r--r--dev-python/sexpdata/Manifest1
-rw-r--r--dev-python/sexpdata/sexpdata-1.0.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/sexpdata/Manifest b/dev-python/sexpdata/Manifest
index 1db82811e710..a0d4e8a4a04a 100644
--- a/dev-python/sexpdata/Manifest
+++ b/dev-python/sexpdata/Manifest
@@ -1,2 +1,3 @@
DIST sexpdata-0.0.3.tar.gz 13105 BLAKE2B 36c4082a63f6748759d71fc38a056ecb7467eafebf0a1a0b006fbef1302488f23a859462c9526dc365f7c88b8b6c331dc6e4892e1d96358abb44ca60a909d283 SHA512 03d4d1557bcc950124e408d6870894c8ee9e72a2ee83c881adf48f8e53bdf3744b4f3e3e133a74a195d236424b434cc690583a68d8395324ca4e84947e548501
DIST sexpdata-0.0.4.gh.tar.gz 16489 BLAKE2B 56a8140fdc92c5802f4c4dc0b699c1492bc7c27aa5999f10a60c5da3ab1f0bcc8875c00ec30c7129064267d63fe21375818b19d0f554d5db5d77936c46c9dc2f SHA512 c3d542000f15ec2220bc5cbff07633ae690fdc676b71d447290f5e20f5930d84840c92cc5827d0dd848f63740ad8edec9583f98df11214a867b212282d5a7236
+DIST sexpdata-1.0.0.gh.tar.gz 16540 BLAKE2B 6babe7b098d9e66bc9cbd6c8a8e91b8d9743ee93ca6745f626421ecab498fc70a02e16e5e3973b97b886feaf4042489f6903736c43f4264252122e1f190b9fc4 SHA512 1ef72d6441907ea3eae00b6d89344281930ac3ad82aee429fa45d2f876aef890019b0bae0241d1670d8f9842dd47a1be76d33dd510b38b09b904334a3924bb56
diff --git a/dev-python/sexpdata/sexpdata-1.0.0.ebuild b/dev-python/sexpdata/sexpdata-1.0.0.ebuild
new file mode 100644
index 000000000000..a8bddef80449
--- /dev/null
+++ b/dev-python/sexpdata/sexpdata-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="a simple S-expression parser/serializer"
+HOMEPAGE="
+ https://github.com/jd-boyd/sexpdata/
+ https://pypi.org/project/sexpdata/
+"
+SRC_URI="
+ https://github.com/jd-boyd/sexpdata/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+distutils_enable_tests pytest