summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-24 07:33:15 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-24 08:04:15 +0100
commit491ec43fb21bd2e212ecbcc6f1a2c39b49e4701a (patch)
treebaa1b2df69e89233cda2665309cb8c0aa5a4be2c /dev-python/sphinxcontrib-applehelp
parentdev-python/sentry-sdk: Bump to 1.14.0 (diff)
downloadgentoo-491ec43fb21bd2e212ecbcc6f1a2c39b49e4701a.tar.gz
gentoo-491ec43fb21bd2e212ecbcc6f1a2c39b49e4701a.tar.bz2
gentoo-491ec43fb21bd2e212ecbcc6f1a2c39b49e4701a.zip
dev-python/sphinxcontrib-applehelp: Bump to 1.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-applehelp')
-rw-r--r--dev-python/sphinxcontrib-applehelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-applehelp/metadata.xml2
-rw-r--r--dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.4.ebuild44
3 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/sphinxcontrib-applehelp/Manifest b/dev-python/sphinxcontrib-applehelp/Manifest
index 5af12bba789a..c80a5ea02b9a 100644
--- a/dev-python/sphinxcontrib-applehelp/Manifest
+++ b/dev-python/sphinxcontrib-applehelp/Manifest
@@ -1,2 +1,3 @@
DIST sphinxcontrib-applehelp-1.0.2.tar.gz 24548 BLAKE2B 9532cb990ed97c6773388a66895a066958187e9100d226e2274c26ba07fc5832e42ba407864b69b002da926a79e71ac2d6315125906156214df3920b585d9f71 SHA512 1325ac83ff15dd28d6f2791caf64e6c08d1dd2f0946dc8891f5c4d8fd062a1e8650c9c39a7459195ef41f3b425f5b8d6c5e277ea85621a36dd870ca5162508da
DIST sphinxcontrib-applehelp-1.0.3.gh.tar.gz 20624 BLAKE2B d9dbd5974527044ecf2d5800da1a3e4b169fdfc2f322006c56ff70f85f3690c95f7f1161693c3bbd14c90a76b8e64035fd3f5bec1529a35f723ae0a47c5967d1 SHA512 d790a58a0b95f90f370c80d198f0e4181485d522d4dcc6e03874c2a2d53b20f84770507a0c956610135d1ad85ccaab68cb287b1e1c463d32c5a0447a5ae49f45
+DIST sphinxcontrib-applehelp-1.0.4.gh.tar.gz 20710 BLAKE2B 9aa6af5b263e6d9603fb01c5ab659bf0cc117341a2c0a6b2946cbd6cdaff0274d17d833d7703711c52e65e8363175e129e452a151fbaab186b8361809bb1a72d SHA512 f281748468a9f5d9a8b71213632d55850b8642b79f33e1e0fb3c6825b0f9b392e0b17b879a8ed0d44d5bea3f076e16f01285d9f41b587af3cf194985e61e92c6
diff --git a/dev-python/sphinxcontrib-applehelp/metadata.xml b/dev-python/sphinxcontrib-applehelp/metadata.xml
index f62d98c651ae..31487ef94bdc 100644
--- a/dev-python/sphinxcontrib-applehelp/metadata.xml
+++ b/dev-python/sphinxcontrib-applehelp/metadata.xml
@@ -7,7 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="pypi">sphinxcontrib.applehelp</remote-id>
+ <remote-id type="pypi">sphinxcontrib-applehelp</remote-id>
<remote-id type="github">sphinx-doc/sphinxcontrib-applehelp</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.4.ebuild b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.4.ebuild
new file mode 100644
index 000000000000..6bfea123328c
--- /dev/null
+++ b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs Apple help book"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-applehelp/
+ https://pypi.org/project/sphinxcontrib-applehelp/
+"
+SRC_URI="
+ https://github.com/sphinx-doc/sphinxcontrib-applehelp/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ cd "${T}" || die
+ epytest "${S}"/tests
+}