summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-07 23:21:20 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-07 23:21:20 +0200
commitf2cb8f3da7f2a11d716deb45e296c586a54a7ebc (patch)
tree607e7655972e5c1a25464e9b80aa8fe5f4ea3f81 /dev-python/spotipy
parentapp-admin/petrovich: EAPI8 bump (diff)
downloadgentoo-f2cb8f3da7f2a11d716deb45e296c586a54a7ebc.tar.gz
gentoo-f2cb8f3da7f2a11d716deb45e296c586a54a7ebc.tar.bz2
gentoo-f2cb8f3da7f2a11d716deb45e296c586a54a7ebc.zip
dev-python/spotipy: bump to 2.23.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python/spotipy')
-rw-r--r--dev-python/spotipy/Manifest1
-rw-r--r--dev-python/spotipy/spotipy-2.23.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/spotipy/Manifest b/dev-python/spotipy/Manifest
index 6264f1545b46..7f08287826ac 100644
--- a/dev-python/spotipy/Manifest
+++ b/dev-python/spotipy/Manifest
@@ -1 +1,2 @@
DIST spotipy-2.22.1.gh.tar.gz 111228 BLAKE2B df75cce406d59c9de3e4c836309262d61f7f1249761d3172be13033512944e69a56ca67f16b55e4736f760b74d3ebd8f384225ce9309a5fc1bd8c93be4099069 SHA512 d8c5871dd606e3335656fb55fa042d8c91c72a4c7d62a584bd407a7546184996694c67d499f908fc7049e406c548269286de6cba17064f0385adba3661b34c3b
+DIST spotipy-2.23.0.gh.tar.gz 112399 BLAKE2B 5510ce35624c561df61fffee78f211dfa91ff8d5b3dc15d37c96a51bf830e67aac9c6a0787c71715bee17a3ba91b84766c1ecec37d5775f2182617f2b74a2cb3 SHA512 52955fa3365d5153f19f60874ce8e96910ac8db783499e0e2ef2ab31127277844e24a045115dc522dd7b7535f7907de56da87e02a63b94ee7506b75c1e108e9b
diff --git a/dev-python/spotipy/spotipy-2.23.0.ebuild b/dev-python/spotipy/spotipy-2.23.0.ebuild
new file mode 100644
index 000000000000..a52000b0bcbc
--- /dev/null
+++ b/dev-python/spotipy/spotipy-2.23.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight Python library for the Spotify Web API"
+HOMEPAGE="
+ https://spotipy.readthedocs.io/
+ https://github.com/spotipy-dev/spotipy/
+ https://pypi.org/project/spotipy/
+"
+SRC_URI="
+ https://github.com/spotipy-dev/spotipy/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/redis[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/unit/test_oauth.py::TestSpotifyClientCredentials::test_spotify_client_credentials_get_access_token
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples
+}