summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-16 00:55:29 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-17 00:06:36 +0200
commit1fd7b8047febc1f392e5ea16b7f838cf825eb2d4 (patch)
tree9f1b84d9a6e114e9e3357613cdef7e0e20c6d0d7 /dev-python/suds
parentwww-misc/urlwatch: add doc (diff)
downloadgentoo-1fd7b8047febc1f392e5ea16b7f838cf825eb2d4.tar.gz
gentoo-1fd7b8047febc1f392e5ea16b7f838cf825eb2d4.tar.bz2
gentoo-1fd7b8047febc1f392e5ea16b7f838cf825eb2d4.zip
dev-python/suds: bump to 0.8.4 from a new fork
Also: * Use EAPI 7. * Require Python built with xml support. * Remove obsolete workarounds. Closes: https://bugs.gentoo.org/644228 Closes: https://github.com/gentoo/gentoo/pull/15041 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/suds')
-rw-r--r--dev-python/suds/Manifest1
-rw-r--r--dev-python/suds/files/suds-0.8.4-fix-optimization.patch11
-rw-r--r--dev-python/suds/suds-0.8.4.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/suds/Manifest b/dev-python/suds/Manifest
index 0234099fcebc..80f647cba466 100644
--- a/dev-python/suds/Manifest
+++ b/dev-python/suds/Manifest
@@ -1 +1,2 @@
DIST suds-0.6.tar.bz2 143985 BLAKE2B 3d97d51b4e719102ab40a6a95a35eaaccda15a47e20bedb0297203576949883eea253ac6f382c8849a522e1720393ec517ec1ff3514329b504c83a928a260881 SHA512 ec078b159bd83c5799e293d9607138ee1da90fdc64da203999555a4324ce7be0235156d3c7ad28e46f84180a6e51e2f3f82228e5e77ae41c61ee20f3db2c916b
+DIST suds-community-0.8.4.tar.gz 279775 BLAKE2B 985dbe386219d7a5cf8b9edb5a30eea2bc974fce5158a1f6e9c7ad3b437efdf0e4d8ff2bddeaf5b5ebc7f0a594adaea3b2db3e47b6dab8143f6cefae248dd061 SHA512 316e67fb2b87ac31cb9397a1620b279e608dc0abead61fa548730fce5b5e29fb2da937c6213f3de6bd06f1e97031f27351938da686fa2f9ce9f4399b9944e0d2
diff --git a/dev-python/suds/files/suds-0.8.4-fix-optimization.patch b/dev-python/suds/files/suds-0.8.4-fix-optimization.patch
new file mode 100644
index 000000000000..3dce3b074751
--- /dev/null
+++ b/dev-python/suds/files/suds-0.8.4-fix-optimization.patch
@@ -0,0 +1,11 @@
+diff --git a/setup.cfg b/setup.cfg
+index c1e1a72..367112f 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -1,6 +1,3 @@
+-[install]
+-optimize = 1
+-
+ [env:2.4.4 x86]
+ command = py244.cmd
+
diff --git a/dev-python/suds/suds-0.8.4.ebuild b/dev-python/suds/suds-0.8.4.ebuild
new file mode 100644
index 000000000000..318f8fadc997
--- /dev/null
+++ b/dev-python/suds/suds-0.8.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_REQ_USE="xml(+)"
+# Tests fail with PyPy3
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+MY_PN="${PN}-community"
+DESCRIPTION="Lightweight SOAP client"
+HOMEPAGE="https://github.com/suds-community/suds"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+# https://github.com/suds-community/suds/pull/40
+PATCHES=( "${FILESDIR}/${P}-fix-optimization.patch" )
+
+DOCS=( README.md notes/. )
+
+distutils_enable_tests pytest