summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-14 13:56:57 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-14 14:30:33 +0100
commit7c449b2e4b1a95b81529d6b6e3c86d45b83c0e70 (patch)
tree5fba05b07d8095045b29aa08036618f621036ce8 /dev-python/tekore
parentnet-misc/curl: version bump 7.82.0 (diff)
downloadgentoo-7c449b2e4b1a95b81529d6b6e3c86d45b83c0e70.tar.gz
gentoo-7c449b2e4b1a95b81529d6b6e3c86d45b83c0e70.tar.bz2
gentoo-7c449b2e4b1a95b81529d6b6e3c86d45b83c0e70.zip
dev-python/tekore: add version 4.3.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/tekore')
-rw-r--r--dev-python/tekore/Manifest1
-rw-r--r--dev-python/tekore/tekore-4.3.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index d4136029fda7..c208925991f1 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1 +1,2 @@
DIST tekore-4.2.0.tar.gz 261053 BLAKE2B 16e76c7e4ff147140bb5a698381249d135e45cb9bcba23ac14c811bfe220c08e8da003ded44526f5d8f46fc9e439d750c3b21560b38b382751a5d0ee834b72eb SHA512 e22232eb7d4ce453e8338b07caad56b04ec35bf7b4ef2207dae450404e62afaca32b29a74155c99918bea75b0cfb80cc847242ff2ec4762abb8a45c1eb6d6d60
+DIST tekore-4.3.0.tar.gz 261287 BLAKE2B 1ac6f828e20d2aa4e591a7b53f6178d1c9f8b760d2daa1f7705d7a45bef5a4973b65fffc1f7571b1bce270efc9c4e8c6d9dd258173cdda94b06e92a4c14352a2 SHA512 bb0aafdda47d5ac4baefc3c057b8ae91d3a243d913f332f69d7dc00f716e6403daaf8d8382e9b25d2810fd65e139f6d427b9749746c8ac61d67b02dc24620969
diff --git a/dev-python/tekore/tekore-4.3.0.ebuild b/dev-python/tekore/tekore-4.3.0.ebuild
new file mode 100644
index 000000000000..9af5c3e33ce6
--- /dev/null
+++ b/dev-python/tekore/tekore-4.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io
+ https://github.com/felix-hilden/tekore
+"
+SRC_URI="https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/httpx-0.23[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( readme.rst )
+
+distutils_enable_tests pytest
+# TODO: package sphinx_codeautolink
+# distutils_enable_sphinx docs/src \
+# dev-python/sphinx_rtd_theme \
+# dev-python/sphinx-tabs \
+# dev-python/sphinx-autodoc-typehints
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
+)