summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-02 22:08:11 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-02 22:08:11 +0300
commit34333b8f4a29fa8f4ba993392439f482090aed27 (patch)
tree3bcf0404015720e1943e421f9c0a04491f04b0c6 /dev-python/untangle
parentnet-libs/libupnpp: remove libtool archive (diff)
downloadgentoo-34333b8f4a29fa8f4ba993392439f482090aed27.tar.gz
gentoo-34333b8f4a29fa8f4ba993392439f482090aed27.tar.bz2
gentoo-34333b8f4a29fa8f4ba993392439f482090aed27.zip
dev-python/untangle: add 1.2.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/untangle')
-rw-r--r--dev-python/untangle/Manifest1
-rw-r--r--dev-python/untangle/untangle-1.2.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/untangle/Manifest b/dev-python/untangle/Manifest
index 5c81cda5ecc1..6bda6a6bb0e1 100644
--- a/dev-python/untangle/Manifest
+++ b/dev-python/untangle/Manifest
@@ -1,2 +1,3 @@
DIST untangle-1.1.1.tar.gz 3089 BLAKE2B d8b8ffe1adb2acbcdcde8e6f67231315b9f318c9e8e1496dfa23b0ac6dd68651e75e2d2e67f6d7d521002ad6b0e9c4cc30c155685b9df60b6b223d137add0632 SHA512 252c3d0ed8d004660adad8f37a179a4d1b2b46e9d7127aee59b596eac3f65684a7a8b5b881bec97ddaf5470aa678df407b903209eaa069a40f53dc2dde9a94b2
DIST untangle-1.2.0.gh.tar.gz 23772 BLAKE2B b93edbd704d2e2664628de2496cd4bf9057501585155bb21dcabe0e56506e697afa11999d2f607119eb3b2a274721a1e29de16ca914391a4e6720b92b964b12c SHA512 83e34702385e69ee172042644fc2d50196e2cbeb403b7a06385e3e3fa701bb132807742453994f724df4bf85fd0915d73ec618c57f4c47995039fa15bb578007
+DIST untangle-1.2.1.gh.tar.gz 24598 BLAKE2B b2f4c43de92dd0fcfcc8f805c91887cc85e9648c3ae83ad95f4c5949ee53c8cf8707e0f2a2e638e47df2b8076d80808116b7666c8e2476857aea5d6ed574186a SHA512 dd0f828b4e1e33bce7d6d735788d36410fb81d4a67b2b449bfd70670ab68df6f5589e12666f515322e998b0df9a0a5ed88130ec17eff86904e5293a5473385ee
diff --git a/dev-python/untangle/untangle-1.2.1.ebuild b/dev-python/untangle/untangle-1.2.1.ebuild
new file mode 100644
index 000000000000..afbb098c7cf3
--- /dev/null
+++ b/dev-python/untangle/untangle-1.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert XML documents into Python objects"
+HOMEPAGE="
+ https://github.com/stchris/untangle/
+ https://pypi.org/project/untangle/
+"
+SRC_URI="
+ https://github.com/stchris/untangle/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest