summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-31 14:05:34 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-31 14:09:38 +0100
commit7e686bf5725e620c6bd9449da4ce31b38131d328 (patch)
treea78c1cb75332e92489114b604c88f279c35708a2 /dev-python/xonsh
parentsys-kernel/vanilla-sources: Version bump of the 3.2.X series. Remove old. (diff)
downloadgentoo-7e686bf5725e620c6bd9449da4ce31b38131d328.tar.gz
gentoo-7e686bf5725e620c6bd9449da4ce31b38131d328.tar.bz2
gentoo-7e686bf5725e620c6bd9449da4ce31b38131d328.zip
dev-python/xonsh: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/xonsh')
-rw-r--r--dev-python/xonsh/Manifest1
-rw-r--r--dev-python/xonsh/xonsh-0.2.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/xonsh/Manifest b/dev-python/xonsh/Manifest
index ff0e8c8ccae1..47f23134f662 100644
--- a/dev-python/xonsh/Manifest
+++ b/dev-python/xonsh/Manifest
@@ -1 +1,2 @@
DIST xonsh-0.2.3.tar.gz 135218 SHA256 e54f045bbcb2c49f8bf67812bc1c1428628745d0b4dd9880c32b4703e51c4a4d SHA512 78cd577765e3116d0b0060a4db6e3e9aaa5bd870fce2e35241eaa00ca1600039d71b4f0ee011f20c959bf72f33ed09a69b4149c8daf377b9151ae0157259c700 WHIRLPOOL d1660a9f0571c8819560412033399cea4d80ee25707b87d84d852d26a7fcb392e0cf8d57f9084e2a3a36eb2ffffa38ae706b5da540cb2015c816efdd52148caf
+DIST xonsh-0.2.4.tar.gz 169491 SHA256 6fa02a32bdc1692992258f26f5bc31c5497143c1c8bd0a8fc279da219122f168 SHA512 17ef284ff57df517e5fc932816fb1ea800107f81aa42a5299d7ed6b2cc46eeaf176c9745b0e70524c0b92c582753b8b6dd586288a4db0ac95e3c4d7b20080cea WHIRLPOOL e472b10f73e785563e4ab457e60bf1702654a6fe2e6bdd35f4972a14485e100bcfb35b5ccbd93c6a55b228a9bd432f0c05287bb4b573bf6727d3e9cf6d8ed976
diff --git a/dev-python/xonsh/xonsh-0.2.4.ebuild b/dev-python/xonsh/xonsh-0.2.4.ebuild
new file mode 100644
index 000000000000..959758a033d2
--- /dev/null
+++ b/dev-python/xonsh/xonsh-0.2.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="An exotic, usable shell"
+HOMEPAGE="
+ http://xonsh.readthedocs.org/
+ https://github.com/scopatz/xonsh
+ http://pypi.python.org/pypi/xonsh"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+"
+DEPEND="${REDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+_PATCHES=(
+ "${FILESDIR}"/${P}-kernel-backport.patch
+ "${FILESDIR}"/${P}-${PN}.bat-backport.patch
+)
+
+python_prepare_all() {
+ sed \
+ -e "/install_kernel_spec/s:prefix=None:prefix=u\"${ED}/usr\":g" \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbose || die
+}
+
+pkg_postinst() {
+ optfeature "Jupyter kernel support" dev-python/jupyter
+ optfeature "Alternative to readline backend" dev-python/prompt_toolkit
+}