summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-23 08:35:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-23 10:16:16 +0200
commit0b1db7b0750e3087b07d5427a5fe505392c3d0f1 (patch)
tree8e504702de9b517fbfc57d87ac904c7194feebc1 /dev-python
parentdev-python/botocore: Bump to 1.21.46 (diff)
downloadgentoo-0b1db7b0750e3087b07d5427a5fe505392c3d0f1.tar.gz
gentoo-0b1db7b0750e3087b07d5427a5fe505392c3d0f1.tar.bz2
gentoo-0b1db7b0750e3087b07d5427a5fe505392c3d0f1.zip
dev-python/boto3: Bump to 1.18.46
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.18.46.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index c462ea866dd9..d31664ca1abf 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.18.42.tar.gz 412699 BLAKE2B d03c4afe357def827e9169ced8b17f92caf79b8
DIST boto3-1.18.43.tar.gz 413685 BLAKE2B 1733a75e17fabdd9941874fd7dfec735cde8702e4df07e5f3c293a9cd83207ae26f7adfc7caeb4913d2fc0d114c4738870b93053ce3e2485f9b4bc3286dabad1 SHA512 5191276feff196503cbd21a44bfd205737ed2c150071037d76198b164c56549b34f36266768f3e5346add393d6c25ad13daf6f6daf74217841d27e305c20c3f1
DIST boto3-1.18.44.tar.gz 413928 BLAKE2B 4cfa75b2dd99f70af521b4da6537cc527f2ab80352b6fb29460ef8759761536023ddb567ef5050d9fa43327542112494b48264bae73bbb95e701ae997e37787c SHA512 cbf142259bf84d0d8a1ba7f2e00d4dff2f66d3adf8fc838d7f3228ce5cc837337907e5351cdafa68fdf6497ce3c7db4543b1254cd6471a81a1ece47f713b1cfe
DIST boto3-1.18.45.tar.gz 419575 BLAKE2B 27896cfc3bd11c13d21bc272b2648917e1f99be5cbb88fd7772388660846dc587d65f21ad22223a310ed1cb264b2a67f8abc3e176df9c7b26a8bab9c4484a386 SHA512 673d727d4b354fa0c790418569832db369215537159abe5343149b63705f3e9f7d9e8f660d26b174b4f2661411afef51b296ebcaef62a6746b7b7853c596216f
+DIST boto3-1.18.46.tar.gz 420373 BLAKE2B 9e354e4ba7b7361734dbfd0ef6296fa2f0c2deae9c42312ae2c6860b09e26acb338a5e06c342622b8384b1b49ff1518975723c6e1a3c988d42611f22f4daec24 SHA512 4bfa76936e7b1f7ddab3d9e4ff16dd59144f0c7acf2d595a3ccc6a186c52ce154f790e11f8c6bed72d0ea14f9c706d1af56a865ad6519e4fea7670f2f3176601
diff --git a/dev-python/boto3/boto3-1.18.46.ebuild b/dev-python/boto3/boto3-1.18.46.ebuild
new file mode 100644
index 000000000000..819e73691110
--- /dev/null
+++ b/dev-python/boto3/boto3-1.18.46.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ ||
+ die "test failed under ${EPYTHON}"
+}