summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-04-16 13:46:30 -0400
committerMike Gilbert <floppym@gentoo.org>2020-04-16 13:46:30 -0400
commit81bcae35ca3f42bc92c1cbf977f5d08d4ea4409c (patch)
treecba6fd50b689d8f16ce3a9b0969612a910b88540 /dev-python
parentdev-python/numpy: fix build with recent distutils-r1 change (diff)
downloadgentoo-81bcae35ca3f42bc92c1cbf977f5d08d4ea4409c.tar.gz
gentoo-81bcae35ca3f42bc92c1cbf977f5d08d4ea4409c.tar.bz2
gentoo-81bcae35ca3f42bc92c1cbf977f5d08d4ea4409c.zip
dev-python/numpy-python2: fix install with recent distutils-r1 change
Bug: https://bugs.gentoo.org/717706 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/numpy-python2/files/numpy-1.16.5-setup.py-install-skip-build-fails.patch23
-rw-r--r--dev-python/numpy-python2/numpy-python2-1.16.5.ebuild1
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/numpy-python2/files/numpy-1.16.5-setup.py-install-skip-build-fails.patch b/dev-python/numpy-python2/files/numpy-1.16.5-setup.py-install-skip-build-fails.patch
new file mode 100644
index 000000000000..aa141de27f48
--- /dev/null
+++ b/dev-python/numpy-python2/files/numpy-1.16.5-setup.py-install-skip-build-fails.patch
@@ -0,0 +1,23 @@
+From b8e741c66f71071c3406e592e1537570731bcb35 Mon Sep 17 00:00:00 2001
+From: mattip <matti.picus@gmail.com>
+Date: Sun, 26 May 2019 08:55:53 +0300
+Subject: [PATCH] BUG: setup.py install --skip-build fails
+
+---
+ numpy/distutils/command/install_clib.py | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/numpy/distutils/command/install_clib.py b/numpy/distutils/command/install_clib.py
+index 662aa00bda9..6a73f7e3308 100644
+--- a/numpy/distutils/command/install_clib.py
++++ b/numpy/distutils/command/install_clib.py
+@@ -19,6 +19,9 @@ def finalize_options(self):
+
+ def run (self):
+ build_clib_cmd = get_cmd("build_clib")
++ if not build_clib_cmd.build_clib:
++ # can happen if the user specified `--skip-build`
++ build_clib_cmd.finalize_options()
+ build_dir = build_clib_cmd.build_clib
+
+ # We need the compiler to get the library name -> filename association
diff --git a/dev-python/numpy-python2/numpy-python2-1.16.5.ebuild b/dev-python/numpy-python2/numpy-python2-1.16.5.ebuild
index d98d86246539..b6c8b4fa6cf0 100644
--- a/dev-python/numpy-python2/numpy-python2-1.16.5.ebuild
+++ b/dev-python/numpy-python2/numpy-python2-1.16.5.ebuild
@@ -50,6 +50,7 @@ S="${WORKDIR}/${MY_PN}-${PV}"
PATCHES=(
"${FILESDIR}"/${MY_PN}-1.15.4-no-hardcode-blas.patch
+ "${FILESDIR}"/numpy-1.16.5-setup.py-install-skip-build-fails.patch
)
src_unpack() {