summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-05 10:29:40 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-05 10:51:54 +0100
commit84f4660095f3c327ea90fc7739423eb0f6ffa4b7 (patch)
tree161ed9979603b0b2f6494f93d807362b757fb957 /dev-python
parentdev-python/reportlab: Bump to 3.5.59 (diff)
downloadgentoo-84f4660095f3c327ea90fc7739423eb0f6ffa4b7.tar.gz
gentoo-84f4660095f3c327ea90fc7739423eb0f6ffa4b7.tar.bz2
gentoo-84f4660095f3c327ea90fc7739423eb0f6ffa4b7.zip
dev-python/sphinx: Bump to 3.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx/Manifest1
-rw-r--r--dev-python/sphinx/sphinx-3.4.2.ebuild128
2 files changed, 129 insertions, 0 deletions
diff --git a/dev-python/sphinx/Manifest b/dev-python/sphinx/Manifest
index 6c72bd82791d..c1b1c3a14619 100644
--- a/dev-python/sphinx/Manifest
+++ b/dev-python/sphinx/Manifest
@@ -3,3 +3,4 @@ DIST Sphinx-3.2.1.tar.gz 5970067 BLAKE2B 6158d31390c9b07aa3abcdc4eb7ed827cf21601
DIST Sphinx-3.3.1.tar.gz 5979919 BLAKE2B 4eb9d8c9dccfd83690252ad6be05a3e69006e1e801bb0b37b77fb6ccf998f3a2fd99a90eba890cfb2baa5545ac0c2734fcd72d602fc2d1091e6754337f241b34 SHA512 bb1fb0780b741c0162ca014cb996dcdaac06985d14b6cc645a835679d7cf2680912784a815a027caf3fe902f721f9707bc9e9daaaf2c2d43051d31fe00584f78
DIST Sphinx-3.4.0.tar.gz 5996932 BLAKE2B 9765d076b7b4738c3d4676618c69d401c49c5f5994f0daf0d04d02ce8c74a8084242910a821333b9233636a195df801f978bf43fbd4d323ad7e9f3651ef33b6e SHA512 49fe0aea70c244416bd26141271074d0f04dd69a8fa37be6d3f6cc3e5e98d4b64fa83ac3bbb80b0b37e8ea05d06bcc5f9891ddc00682e1c3c14130f48a831971
DIST Sphinx-3.4.1.tar.gz 5997545 BLAKE2B 18bca0e05f0226785f96d108b08ed8a41638f1ce1678578a16666cde66b1a3a1d2a8cafa0213157fbb6aa5f471a7e2e8154f47e9b1a0c1ba017d0a86145a19cb SHA512 feaf20046dc82ca94c1d80e90e232dd3d183830202ef48f51599a58e3a8f255d5d746293926757e326d9fe1bd43b62bd9c29c265ad83baa34a7631b5b3cbd7a0
+DIST Sphinx-3.4.2.tar.gz 5996867 BLAKE2B 4ab0989d521702a5e84148d12f57c2332d27519807de1aa33fff3a17813c8be0247e413c768cd3062c4c52372607cc6f5f16ca0a2ff46cbb8e73db4dd7270796 SHA512 7af39a6c40f54018cce59c2407af278bcbfbded305742918d053e75ae7bdc3a1ea8cc615fd554c9f9581c84723cf5f70ebed8916c54215c5024cf63e31dd3a0e
diff --git a/dev-python/sphinx/sphinx-3.4.2.ebuild b/dev-python/sphinx/sphinx-3.4.2.ebuild
new file mode 100644
index 000000000000..ca0c81f75165
--- /dev/null
+++ b/dev-python/sphinx/sphinx-3.4.2.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python documentation generator"
+HOMEPAGE="https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinx"
+SRC_URI="mirror://pypi/S/${PN^}/${P^}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="doc latex test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/alabaster-0.8[${PYTHON_USEDEP}]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/imagesize[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/snowballstemmer[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-devhelp[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-jsmath[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-htmlhelp[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-serializinghtml[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-qthelp[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typed-ast[${PYTHON_USEDEP}]
+ ' python3_{6,7})
+ latex? (
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-luatex
+ app-text/dvipng
+ )"
+BDEPEND="
+ doc? (
+ dev-python/sphinxcontrib-websupport[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ virtual/imagemagick-tools[jpeg,png,svg]
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-luatex
+ app-text/dvipng
+ )"
+
+S="${WORKDIR}/${P^}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.2.1-doc-link.patch"
+)
+
+python_prepare_all() {
+ # disable internet access
+ sed -i -e 's:^intersphinx_mapping:disabled_&:' \
+ doc/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ # Generate the grammar. It will be caught by install somehow.
+ # Note that the tests usually do it for us. However, I don't want
+ # to trust USE=test really running all the tests, especially
+ # with FEATURES=test-fail-continue.
+ pushd "${BUILD_DIR}"/lib >/dev/null || die
+ "${EPYTHON}" -m sphinx.pycode.__init__ || die "Grammar generation failed."
+ popd >/dev/null || die
+}
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ fi
+}
+
+python_test() {
+ mkdir -p "${BUILD_DIR}/sphinx_tempdir" || die
+ local -x SPHINX_TEST_TEMPDIR="${BUILD_DIR}/sphinx_tempdir"
+
+ local deselect=(
+ # these tests require Internet access
+ tests/test_build_latex.py::test_latex_images
+ tests/test_build_linkcheck.py::test_defaults
+ tests/test_build_linkcheck.py::test_defaults_json
+ tests/test_build_linkcheck.py::test_anchors_ignored
+ )
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ tests/test_build_latex.py::test_latex_images
+ tests/test_ext_autodoc.py::test_autodoc_inherited_members_None
+ tests/test_ext_autodoc.py::test_automethod_for_builtin
+ tests/test_ext_autodoc.py::test_partialfunction
+ tests/test_ext_autodoc.py::test_autodoc_typed_instance_variables
+ tests/test_ext_autodoc.py::test_autodoc_typed_inherited_instance_variables
+ tests/test_ext_autodoc.py::test_cython
+ tests/test_ext_autodoc_autoclass.py::test_show_inheritance_for_subclass_of_generic_type
+ tests/test_ext_autodoc_autodata.py::test_autodata_type_comment
+ tests/test_ext_autodoc_autofunction.py::test_builtin_function
+ tests/test_ext_autodoc_autofunction.py::test_methoddescriptor
+ tests/test_ext_autodoc_configs.py::test_autodoc_typehints_signature
+ tests/test_ext_autodoc_configs.py::test_autodoc_type_aliases
+ tests/test_ext_autosummary.py::test_autosummary_generate_content_for_module
+ tests/test_ext_autosummary.py::test_autosummary_generate_content_for_module_skipped
+ tests/test_pycode_parser.py::test_annotated_assignment_py36
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests fail with ${EPYTHON}"
+}