summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-11-04 21:01:33 +0100
committerFabian Groffen <grobian@gentoo.org>2024-11-04 21:02:49 +0100
commit85d5f8711e34207fdf5aa4a5796972a937b81b28 (patch)
treec293c53acb593ed10ca5849d476808be6fd1b0f0 /dev-python
parentsys-apps/baselayout: update EAPI 7 -> 8 (diff)
downloadgentoo-85d5f8711e34207fdf5aa4a5796972a937b81b28.tar.gz
gentoo-85d5f8711e34207fdf5aa4a5796972a937b81b28.tar.bz2
gentoo-85d5f8711e34207fdf5aa4a5796972a937b81b28.zip
dev-python/dulwich-0.22.4: avoid hard rust dep
hack setup.py not to require setuptools_rust so a rust-free system can install this Pure Python package with USE=-native-extensions Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dulwich/dulwich-0.22.4.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/dev-python/dulwich/dulwich-0.22.4.ebuild b/dev-python/dulwich/dulwich-0.22.4.ebuild
index 294fd2a15e19..20b5987431a8 100644
--- a/dev-python/dulwich/dulwich-0.22.4.ebuild
+++ b/dev-python/dulwich/dulwich-0.22.4.ebuild
@@ -73,6 +73,18 @@ src_unpack() {
cargo_src_unpack
}
+src_prepare() {
+ default
+
+ if use !native-extensions; then
+ # avoid hard dep on rust via setuptools_rust
+ sed -i \
+ -e '/from setuptools_rust/d' \
+ -e '/^rust_extensions = \[/,/^\]/d' \
+ setup.py || die
+ fi
+}
+
python_compile() {
unset PURE
# TODO: enable Rust extensions