summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-23 20:39:19 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-23 20:39:19 +0300
commit9351875e5fc9b0abf1d7bcb9e151570a7d6bf74c (patch)
treebcbeef6a2b72d34f5687419112a73129d29396d4 /dev-python
parentsys-auth/docker_auth: fix "go mod verify" failure (diff)
downloadgentoo-9351875e5fc9b0abf1d7bcb9e151570a7d6bf74c.tar.gz
gentoo-9351875e5fc9b0abf1d7bcb9e151570a7d6bf74c.tar.bz2
gentoo-9351875e5fc9b0abf1d7bcb9e151570a7d6bf74c.zip
dev-python/python-cstruct: add 3.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-cstruct/Manifest1
-rw-r--r--dev-python/python-cstruct/python-cstruct-3.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-cstruct/Manifest b/dev-python/python-cstruct/Manifest
index 90375f68b95f..7821b2bd0c76 100644
--- a/dev-python/python-cstruct/Manifest
+++ b/dev-python/python-cstruct/Manifest
@@ -2,3 +2,4 @@ DIST python-cstruct-2.2.gh.tar.gz 18764 BLAKE2B 75aaffae27fef59799e52866f8169cc5
DIST python-cstruct-2.3.gh.tar.gz 19043 BLAKE2B dd445da91d155dc576523d5c15dc963493dfb62e7e79fae6c436e69654432eadbc30b0001026f5613268800eb0a3a01392120b11e7b3995cff16477850818c9f SHA512 5700a3d8ef58130bc5b3b5d7c36102f6a878fd8d5b9104804f0c206e583e77d7a9c9ff8e8008d9bd1ee72d55167e48cd3f9ba776816eb25ceb8ceaf0c880b597
DIST python-cstruct-3.0.gh.tar.gz 25950 BLAKE2B 7ea8c77ed87e4fb740c3f7a4ed53a7532ee5aca15ee46fbb40da7308ae62ceacd7ccc67a958e6355904604ae67c9594acc9cae5d18bfed0558b91f7e9c8ad0a9 SHA512 dd1c85363512edc4df0379dec40e7d7fe3ceff1cc4014eae8dab0e91c47ea9c3619211e1a637aeec134ce713d0681688630b7fde97f02c6bcd7103a32f258a73
DIST python-cstruct-3.1.gh.tar.gz 26633 BLAKE2B 449510cc8cc6661270d2618cd347eea2044eacc8f665ed2f55bc6fcd95bcf79f29f8bce6498d372d8b5b78f854edb06afb89a3f3ef7f5de37582ebf68d178db1 SHA512 00e2165c14dcc4461600a8eeef5c71bcaa6e59955c23d08055aff2186b16f20d6c10fdb1a02f6e263e27070fda562c712df0c4ad2440a25dc5f23afaa9c88719
+DIST python-cstruct-3.2.gh.tar.gz 26876 BLAKE2B 084c4e3e1e5a48ee15c40e25a846b09dc1af1fe0ef9734bddad14ebac91e2bbdf78cffc39dd861f35d7ed307f1dfb14cb7b15dd47b900d3c943bf3245adb9ff3 SHA512 8b912bba7a31a8cacd77e07008ea1a0603c59c49e2cbb4a8fee158948b05166f2223c983f58c104d73c0fd868bfaebc9f38669277f27282486cfb064d9026ab5
diff --git a/dev-python/python-cstruct/python-cstruct-3.2.ebuild b/dev-python/python-cstruct/python-cstruct-3.2.ebuild
new file mode 100644
index 000000000000..7b8d01c50942
--- /dev/null
+++ b/dev-python/python-cstruct/python-cstruct-3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="https://github.com/andreax79/python-cstruct
+ https://pypi.org/project/cstruct/"
+SRC_URI="
+ https://github.com/andreax79/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ sed -e "/find_packages(/s@exclude=\[@&'tests', @" -i setup.py || die
+}