summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-28 13:47:43 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-28 13:50:42 +0200
commit9c9be7aed5a49a06c58e938d9d1addd41303debe (patch)
treeadc6bc09b562184723fb85043ce52b4e3e0c8e01 /dev-python
parentdev-python/ruamel-std-pathlib: add 0.9.1 (diff)
downloadgentoo-9c9be7aed5a49a06c58e938d9d1addd41303debe.tar.gz
gentoo-9c9be7aed5a49a06c58e938d9d1addd41303debe.tar.bz2
gentoo-9c9be7aed5a49a06c58e938d9d1addd41303debe.zip
dev-python/mygpoclient: enable py3.10, ebuild cleanup
Closes: https://bugs.gentoo.org/745948 Closes: https://bugs.gentoo.org/723736 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mygpoclient/files/mygpoclient-1.8-fix-literal.patch35
-rw-r--r--dev-python/mygpoclient/mygpoclient-1.8.ebuild36
2 files changed, 48 insertions, 23 deletions
diff --git a/dev-python/mygpoclient/files/mygpoclient-1.8-fix-literal.patch b/dev-python/mygpoclient/files/mygpoclient-1.8-fix-literal.patch
new file mode 100644
index 000000000000..372d0bc2bc40
--- /dev/null
+++ b/dev-python/mygpoclient/files/mygpoclient-1.8-fix-literal.patch
@@ -0,0 +1,35 @@
+From bdf8c8ce38cff8938bab3544c6dbb0d509ce7720 Mon Sep 17 00:00:00 2001
+From: Eric Le Lay <elelay@macports.org>
+Date: Sun, 22 Mar 2020 16:19:08 +0100
+Subject: [PATCH] use == for comparison with literal
+
+See https://bugs.python.org/issue34850
+---
+ mygpoclient/locator.py | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/mygpoclient/locator.py b/mygpoclient/locator.py
+index c0dc9d7..810f973 100644
+--- a/mygpoclient/locator.py
++++ b/mygpoclient/locator.py
+@@ -317,17 +317,17 @@ def settings_uri(self, type, scope_param1, scope_param2):
+
+ filename = self._username + '/%(type)s.json' % locals()
+
+- if type is 'device':
++ if type == 'device':
+ if scope_param1 is None:
+ raise ValueError('Devicename not specified')
+ filename += '?device=%(scope_param1)s' % locals()
+
+- if type is 'podcast':
++ if type == 'podcast':
+ if scope_param1 is None:
+ raise ValueError('Podcast URL not specified')
+ filename += '?podcast=%s' % quote(scope_param1)
+
+- if type is 'episode':
++ if type == 'episode':
+ if (scope_param1 is None) or (scope_param2 is None):
+ raise ValueError('Podcast or Episode URL not specified')
+ filename += '?podcast=%s&episode=%s' % (quote(scope_param1), quote(scope_param2))
diff --git a/dev-python/mygpoclient/mygpoclient-1.8.ebuild b/dev-python/mygpoclient/mygpoclient-1.8.ebuild
index 9c66b03f5c3a..7992f3b024a2 100644
--- a/dev-python/mygpoclient/mygpoclient-1.8.ebuild
+++ b/dev-python/mygpoclient/mygpoclient-1.8.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A gpodder.net client library"
@@ -14,34 +14,24 @@ SRC_URI="https://github.com/gpodder/mygpoclient/archive/${PV}.tar.gz -> ${P}.tar
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/minimock
- )
-"
+BDEPEND="test? ( dev-python/minimock[${PYTHON_USEDEP}] )"
-PATCHES=( "${FILESDIR}"/${P}-tests.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-literal.patch
+ "${FILESDIR}"/${PN}-1.8-tests.patch
+)
+
+distutils_enable_tests nose
src_prepare() {
- distutils-r1_src_prepare
# Disable tests requring network connection.
- rm -f mygpoclient/http_test.py
-}
+ rm mygpoclient/http_test.py || die
-python_test() {
- if [[ "${EPYTHON:0:4}" == "pypy" ]]; then
- nosetests --cover-erase --with-coverage --cover-package=mygpoclient "${BUILD_DIR}"/lib/${PN}/
- else
- nosetests --cover-erase --with-coverage --with-doctest --cover-package=mygpoclient "${BUILD_DIR}"/lib/${PN}/
- fi
+ distutils-r1_src_prepare
}
src_install() {
distutils-r1_src_install
- rm -f $(find "${D}" -name "*_test.py")
+ find "${D}" -name "*_test.py" -delete || die
}