summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-24 06:05:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-24 07:14:03 +0200
commita60a9a1746d3a10aaf646f69ff46dd81321ef529 (patch)
tree35d903cd56c91bf85c0cf3fbeac568a7b5001704 /dev-python
parentdev-python/denonavr: Bump to 0.10.12 (diff)
downloadgentoo-a60a9a1746d3a10aaf646f69ff46dd81321ef529.tar.gz
gentoo-a60a9a1746d3a10aaf646f69ff46dd81321ef529.tar.bz2
gentoo-a60a9a1746d3a10aaf646f69ff46dd81321ef529.zip
dev-python/dill: Bump to 0.3.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dill/Manifest1
-rw-r--r--dev-python/dill/dill-0.3.6.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
index a9584008136c..30211d4ca627 100644
--- a/dev-python/dill/Manifest
+++ b/dev-python/dill/Manifest
@@ -1 +1,2 @@
DIST dill-0.3.5.1.gh.tar.gz 161203 BLAKE2B 2f778f3d2792d5606f8a5d7fd7d993490592da5ade701a38a270f756d129ad49f2aa44277fcb1f69a14779fe2541e2a720dc643ebd0fad258725d5d9452c048f SHA512 3dcf5e262110031412d9dfaee5548fed80bfc4d6b404cddbc2d9a6f65e2b80fae45a622ef73768e7996d2fc9e8d2757ac04e2a73f3700c526037dbabaa8adf15
+DIST dill-0.3.6.gh.tar.gz 171608 BLAKE2B 3b0c6f20218230685c91c10edb4d9bfdbb913464903ce03c92c85ad607ab3973c61c39f9a9807d55c1d3aa3736f5de4575e5beb0784f2b17f0af850210bebd61 SHA512 921bd5122b9b90fd3426a7af5fc8ba70d09b92d740951f5db5d481abb280915d722410f174ab028134acff9a3659899c8f315242caa7a44d8e4b38dd02bb1fa3
diff --git a/dev-python/dill/dill-0.3.6.ebuild b/dev-python/dill/dill-0.3.6.ebuild
new file mode 100644
index 000000000000..1f68f4b57d03
--- /dev/null
+++ b/dev-python/dill/dill-0.3.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of Python (almost)"
+HOMEPAGE="
+ https://github.com/uqfoundation/dill/
+ https://pypi.org/project/dill/
+"
+SRC_URI="
+ https://github.com/uqfoundation/dill/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ "${EPYTHON}" -m dill.tests || die
+}