summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-13 19:15:16 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-13 19:31:26 +0300
commitdf38e10fa1a1480d86ffc72080c3f30770c8a95c (patch)
tree1c3fcc51cb6187c9d00f8d39b845ce95caff43ae /dev-python
parentdev-python/jaraco-logging: enable py3.11 (diff)
downloadgentoo-df38e10fa1a1480d86ffc72080c3f30770c8a95c.tar.gz
gentoo-df38e10fa1a1480d86ffc72080c3f30770c8a95c.tar.bz2
gentoo-df38e10fa1a1480d86ffc72080c3f30770c8a95c.zip
dev-python/jaraco-collections: Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.5.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.5.1-r1.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.5.1-r1.ebuild
new file mode 100644
index 000000000000..97771dd5c2aa
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.5.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/jaraco-packaging-3.2' \
+ '>=dev-python/rst-linker-1.9'
+distutils_enable_tests pytest