summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-11 18:13:59 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-11 18:13:59 +0200
commiteac24e7aa17cdc2ee69d4564663aa20a1331fcc9 (patch)
tree7827eca7f70cdb413752873194f26917dc70cb83 /dev-python
parentdev-python/weasyprint: Remove old (diff)
downloadgentoo-eac24e7aa17cdc2ee69d4564663aa20a1331fcc9.tar.gz
gentoo-eac24e7aa17cdc2ee69d4564663aa20a1331fcc9.tar.bz2
gentoo-eac24e7aa17cdc2ee69d4564663aa20a1331fcc9.zip
dev-python/joblib: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/joblib/Manifest1
-rw-r--r--dev-python/joblib/joblib-1.1.0-r1.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/joblib/Manifest b/dev-python/joblib/Manifest
index e85abfb4041b..8873889b7f93 100644
--- a/dev-python/joblib/Manifest
+++ b/dev-python/joblib/Manifest
@@ -1,2 +1 @@
-DIST joblib-1.1.0.tar.gz 350428 BLAKE2B 6b9b449e012752e561b267c8e27475252fee8d56406430bc570abc6da22b913bb09b7ad8708c29c7d7c338e4f541144b4514976a9f4ce017c3764b4d717eaba8 SHA512 5efcf9fc6dd4e2cf30599dc50373e40580be38fa15c2295519eb8c3b94a07b0fe2d1a9960ec4a67846aa3176335a2634b21107664032966166b973dcbded0cea
DIST joblib-1.2.0.gh.tar.gz 345345 BLAKE2B e18be536054829057ff320eda320a7548434108b3fc6c92a03df73dc68e093d039c656c1d674ea26fb6419bdfc39d26cfc28236a6bfbf0dcbf3ace7e52b0c829 SHA512 de882f2ff8dd936b4f98352b9ee1cc56c3a734f215a74257cf90a25736afd9e6b93e6538929b7a29f5956e6fccbdfcbf8b39c8fd68035a8857721f7a76066133
diff --git a/dev-python/joblib/joblib-1.1.0-r1.ebuild b/dev-python/joblib/joblib-1.1.0-r1.ebuild
deleted file mode 100644
index 0564a64a7661..000000000000
--- a/dev-python/joblib/joblib-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-DESCRIPTION="Tools to provide lightweight pipelining in Python"
-HOMEPAGE="https://joblib.readthedocs.io/en/latest/
- https://github.com/joblib/joblib"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 ~riscv x86"
-
-RDEPEND="
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- dev-python/loky[${PYTHON_USEDEP}]
-"
-# joblib is imported by setup.py so we need ${RDEPEND}
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/threadpoolctl[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # unbundle
- rm -r joblib/externals || die
- sed -e "s:'joblib.externals[^']*',\?::g" -i setup.py || die
- find -name '*.py' -exec \
- sed -e 's:\(joblib\)\?\.externals\.::' \
- -e 's:from \.externals ::' \
- -i {} + || die
-
- # https://github.com/joblib/joblib/issues/1115
- sed -e 's:test_parallel_call_cached_function_defined_in_jupyter:_&:' \
- -i joblib/test/test_memory.py || die
-
- distutils-r1_python_prepare_all
-}