summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-28 03:05:20 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-28 08:31:19 -0400
commit3bbbaecf8ff805c4c5052373a4332d1795c4cc05 (patch)
treeea9fc6e8d6c8daaa5b6d09fb8091b0f9e93b5f3e /dev-qt/qtconnectivity
parentsys-fs/erofs-utils: keyword 1.7 for ~loong (diff)
downloadgentoo-3bbbaecf8ff805c4c5052373a4332d1795c4cc05.tar.gz
gentoo-3bbbaecf8ff805c4c5052373a4332d1795c4cc05.tar.bz2
gentoo-3bbbaecf8ff805c4c5052373a4332d1795c4cc05.zip
dev-qt/*: drop 6.5.9999
Technically an LTS branch but 6.5.3 is due to be the last "public" release for this branch plus Plasma 6 is based on 6.6, so should have no use for this anymore. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtconnectivity')
-rw-r--r--dev-qt/qtconnectivity/qtconnectivity-6.5.9999.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/dev-qt/qtconnectivity/qtconnectivity-6.5.9999.ebuild b/dev-qt/qtconnectivity/qtconnectivity-6.5.9999.ebuild
deleted file mode 100644
index 47506d7b4b09..000000000000
--- a/dev-qt/qtconnectivity/qtconnectivity-6.5.9999.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Bluetooth and NFC support library for the Qt6 framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64"
-fi
-
-IUSE="+bluetooth nfc smartcard"
-REQUIRED_USE="|| ( bluetooth nfc )"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[network]
- bluetooth? (
- ~dev-qt/qtbase-${PV}:6[dbus]
- net-wireless/bluez:=
- )
- nfc? (
- smartcard? ( sys-apps/pcsc-lite )
- )
-"
-DEPEND="${RDEPEND}"
-
-CMAKE_SKIP_TESTS=(
- # most hardware tests are auto-skipped, but some still misbehave
- # if bluez/hardware is available (generally tests here may not be
- # very relevant without hardware, lists may need to be extended)
- tst_qbluetoothlocaldevice
- tst_qbluetoothserver
- tst_qbluetoothservicediscoveryagent
- tst_qbluetoothserviceinfo
- tst_qlowenergycontroller
-)
-
-src_prepare() {
- qt6-build_src_prepare
-
- use bluetooth ||
- sed -i '/add_subdirectory(bluetooth)/d' src/CMakeLists.txt || die
- use nfc ||
- sed -i '/add_subdirectory(nfc)/d' src/CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- $(usev nfc $(qt_feature smartcard pcsclite))
- )
-
- qt6-build_src_configure
-}
-
-src_install() {
- qt6-build_src_install
-
- # broken (unnecessary) symlink due to add_app() being used over add_tool()
- use !bluetooth || rm -- "${ED}"/usr/bin/sdpscanner6 || die
-
- if use test; then
- local delete=( # sigh
- "${D}${QT6_BINDIR}"/bluetoothtestdevice
- "${D}${QT6_BINDIR}"/bttestui
- "${D}${QT6_BINDIR}"/qlecontroller-server
- )
- # using -f given not tracking which tests may be skipped or not
- rm -f -- "${delete[@]}" || die
- fi
-}