summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2023-04-15 21:39:22 +0300
committerJimi Huotari <chiitoo@gentoo.org>2023-04-15 21:39:22 +0300
commit0c00b3327f37548bb1d042bb2ca2104c9570a9fa (patch)
treecd4d4b8f769686a0e756de2e099397666073929c /dev-qt/qtlocation
parentdev-qt/qtcharts: add 6.5.0 (diff)
downloadgentoo-0c00b3327f37548bb1d042bb2ca2104c9570a9fa.tar.gz
gentoo-0c00b3327f37548bb1d042bb2ca2104c9570a9fa.tar.bz2
gentoo-0c00b3327f37548bb1d042bb2ca2104c9570a9fa.zip
dev-qt/qtlocation: add 6.5.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-6.5.0.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 7c2155f15920..b0c8e29b7d23 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -2,4 +2,5 @@ DIST qtlocation-5.15.8-gentoo-kde-1.tar.xz 3952 BLAKE2B 6084d14533ca2ba44249db81
DIST qtlocation-5.15.9-gentoo-kde-1.tar.xz 3968 BLAKE2B a36b202400894ea4b5f377381a5870e88022c5a20e1adec4515745bc2606b7f0180ff30435724218c0f1ef130cbf29f57a0c6c7f4f48b9b3689c7aa8bb2bfa73 SHA512 e043e0537ecb66372b9464fd2d49bc8d6297bb29e5ceddc171d3899fd42a57cf129782c85efab6d5d3bc7dc3db91ba623161f7369861e9a7b6623e557dd8834e
DIST qtlocation-everywhere-opensource-src-5.15.8.tar.xz 6559180 BLAKE2B 1b8feb5da8d564a6605d9106ec6399aea23a4f0b43f495baf61e14266e90d2d73cd310fb6d8514730867acba1aa26efb3072c213f22f19f72c2f554d76ab281b SHA512 a337fade917150c13fa2ea22ad1949f41541cea4ceb1f732ab53c20c2f19a63dcfc6f9f544ca64fdb5703d3ac8d2ec6e832f1f199a32e73a2f6c51febf53f514
DIST qtlocation-everywhere-opensource-src-5.15.9.tar.xz 6552244 BLAKE2B 5091aef5706313660dd6fe5d831d0a9b8b6160739c1cce115e6a42a0b2ff3020ff0cd51a99bff9d24ccd29952b259fd1953bd5691ae4c3b2cbb8f31d3e9107f8 SHA512 37517c304240921c600e2aad19baff0efbb5e01c5cc78e5370fb4b084f2a6ba4da94d39ddcbcd33a5f0af37f017d39bb775a40cda195e16697aa70c9d17b6bcf
+DIST qtlocation-everywhere-src-6.5.0.tar.xz 3038252 BLAKE2B 5530b37669f29c8f616daf2028ce27b712352863299ccf77fcc5a89999e34ab8e3a00c60ba30ef01b1c4337a519261be8288f3c4be0da18a840d418381bcc1f2 SHA512 e0b0c8f4093436aa53661fbcea885ee86565ff8e61bae4b567be24e7251e56b77071b78e160903ddc487b36931ce6f1a525c74135cd360cdd1d189da4463a96d
DIST qtlocation-mapboxgl-5.15.9-5a07e196.tar.gz 3726230 BLAKE2B 9dbe08088a55bc1da4952a628af987b3b056615e883983d3a5e2eb392ce4aff16bfd753f84bbad07f9a415fbd275ec9933a64b6bcfd27ea6d8adced6d2adcac7 SHA512 ec3de81f643388690eda45d073a9c6f908d8efeff30cd062d9afcd1f94c6b45b301327747928d45b4047ce04b7df5b0afaf9e8942e22660711a5ac49787829eb
diff --git a/dev-qt/qtlocation/qtlocation-6.5.0.ebuild b/dev-qt/qtlocation/qtlocation-6.5.0.ebuild
new file mode 100644
index 000000000000..cd6b3e19feb4
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-6.5.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*
+ =dev-qt/qtdeclarative-${PV}*
+"
+RDEPEND="${DEPEND}"