summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 14:15:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 14:33:32 +0200
commit1f575001f93f5032fdd05fa648e1c1bea44aa05c (patch)
treedfa2f844d671f557765636cda19b07adc47a730d /dev-ros/interval_intersection
parentdev-ros/joint_states_settler: bump eapi (diff)
downloadgentoo-1f575001f93f5032fdd05fa648e1c1bea44aa05c.tar.gz
gentoo-1f575001f93f5032fdd05fa648e1c1bea44aa05c.tar.bz2
gentoo-1f575001f93f5032fdd05fa648e1c1bea44aa05c.zip
dev-ros/interval_intersection: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/interval_intersection')
-rw-r--r--dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild10
-rw-r--r--dev-ros/interval_intersection/interval_intersection-9999.ebuild9
2 files changed, 8 insertions, 11 deletions
diff --git a/dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild b/dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild
index e814990288f3..84f4c391c2e3 100644
--- a/dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild
+++ b/dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/calibration"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
CATKIN_HAS_MESSAGES=yes
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"
inherit ros-catkin
-DESCRIPTION="Tools for calculating the intersection of interval messages coming in on several topics"
+DESCRIPTION="Tools for calculating the intersection of interval messages"
LICENSE="BSD"
SLOT="0"
IUSE=""
@@ -19,12 +18,11 @@ IUSE=""
RDEPEND="
dev-libs/boost:=[threads]
dev-ros/actionlib
- dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/rosconsole
dev-ros/roscpp
dev-ros/roscpp_serialization
dev-ros/rostime
"
DEPEND="${RDEPEND}
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? ( dev-cpp/gtest )"
-PATCHES=( "${FILESDIR}/gcc6.patch" )
diff --git a/dev-ros/interval_intersection/interval_intersection-9999.ebuild b/dev-ros/interval_intersection/interval_intersection-9999.ebuild
index bf87d040c0f6..84f4c391c2e3 100644
--- a/dev-ros/interval_intersection/interval_intersection-9999.ebuild
+++ b/dev-ros/interval_intersection/interval_intersection-9999.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/calibration"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
CATKIN_HAS_MESSAGES=yes
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"
inherit ros-catkin
-DESCRIPTION="Tools for calculating the intersection of interval messages coming in on several topics"
+DESCRIPTION="Tools for calculating the intersection of interval messages"
LICENSE="BSD"
SLOT="0"
IUSE=""
@@ -19,11 +18,11 @@ IUSE=""
RDEPEND="
dev-libs/boost:=[threads]
dev-ros/actionlib
- dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/rosconsole
dev-ros/roscpp
dev-ros/roscpp_serialization
dev-ros/rostime
"
DEPEND="${RDEPEND}
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? ( dev-cpp/gtest )"