summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-28 18:07:54 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-28 20:10:23 +0100
commit81626af23ac33530cfe5b53fcdc783814696de96 (patch)
treed66900a661ecbfe3bc0ee5f46baa847eb8eec2b2 /dev-ros/nodelet/nodelet-1.9.14-r1.ebuild
parentdev-ros/nodelet: Remove old (diff)
downloadgentoo-81626af23ac33530cfe5b53fcdc783814696de96.tar.gz
gentoo-81626af23ac33530cfe5b53fcdc783814696de96.tar.bz2
gentoo-81626af23ac33530cfe5b53fcdc783814696de96.zip
dev-ros/nodelet: add missing := dep on tinyxml and console bridge
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ros/nodelet/nodelet-1.9.14-r1.ebuild')
-rw-r--r--dev-ros/nodelet/nodelet-1.9.14-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/nodelet/nodelet-1.9.14-r1.ebuild b/dev-ros/nodelet/nodelet-1.9.14-r1.ebuild
new file mode 100644
index 000000000000..94c0ffd3b95f
--- /dev/null
+++ b/dev-ros/nodelet/nodelet-1.9.14-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/nodelet_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a way to run multiple algorithms in the same process with zero copy transport"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bondcpp
+ dev-ros/cmake_modules
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/rosconsole
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-libs/boost:=
+ sys-apps/util-linux
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"