summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-10 10:47:41 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-10 11:34:51 +0100
commitea91b9d3c067e093443949163c03f349ca19bec2 (patch)
tree5d342956e8da6c3a84d91186e58e1c4c79a361ad /dev-ros/rostime/rostime-0.5.7.ebuild
parentdev-ros/cpp_common: Bump to 0.5.7. (diff)
downloadgentoo-ea91b9d3c067e093443949163c03f349ca19bec2.tar.gz
gentoo-ea91b9d3c067e093443949163c03f349ca19bec2.tar.bz2
gentoo-ea91b9d3c067e093443949163c03f349ca19bec2.zip
dev-ros/rostime: Bump to 0.5.7.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rostime/rostime-0.5.7.ebuild')
-rw-r--r--dev-ros/rostime/rostime-0.5.7.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rostime/rostime-0.5.7.ebuild b/dev-ros/rostime/rostime-0.5.7.ebuild
new file mode 100644
index 000000000000..e673fcc54390
--- /dev/null
+++ b/dev-ros/rostime/rostime-0.5.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Time and Duration implementations for C++ libraries"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/cpp_common
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"