summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-14 11:50:21 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-14 12:38:20 +0100
commit1f9a860a9652f91eb0e9db531442cb666e774006 (patch)
tree6d989523950a3131d4885b77231dd08009668003 /dev-ros/rostopic/rostopic-1.11.17.ebuild
parentdev-ros/rostest: Bump to 1.11.17. (diff)
downloadgentoo-1f9a860a9652f91eb0e9db531442cb666e774006.tar.gz
gentoo-1f9a860a9652f91eb0e9db531442cb666e774006.tar.bz2
gentoo-1f9a860a9652f91eb0e9db531442cb666e774006.zip
dev-ros/rostopic: Bump to 1.11.17.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rostopic/rostopic-1.11.17.ebuild')
-rw-r--r--dev-ros/rostopic/rostopic-1.11.17.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/rostopic/rostopic-1.11.17.ebuild b/dev-ros/rostopic/rostopic-1.11.17.ebuild
new file mode 100644
index 000000000000..c3438a04756b
--- /dev/null
+++ b/dev-ros/rostopic/rostopic-1.11.17.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS Topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"