summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-28 19:51:25 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-28 20:10:48 +0100
commita73945d0351d4c2fe7b4390662ef94dd644d362b (patch)
tree213409b7679289c9f073b24f71a6b5ce7891fed4 /dev-ros/rqt_rviz/rqt_rviz-0.5.8-r1.ebuild
parentdev-ros/rqt_rviz: Remove old (diff)
downloadgentoo-a73945d0351d4c2fe7b4390662ef94dd644d362b.tar.gz
gentoo-a73945d0351d4c2fe7b4390662ef94dd644d362b.tar.bz2
gentoo-a73945d0351d4c2fe7b4390662ef94dd644d362b.zip
dev-ros/rqt_rviz: add missing console bridge dep
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ros/rqt_rviz/rqt_rviz-0.5.8-r1.ebuild')
-rw-r--r--dev-ros/rqt_rviz/rqt_rviz-0.5.8-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/rqt_rviz/rqt_rviz-0.5.8-r1.ebuild b/dev-ros/rqt_rviz/rqt_rviz-0.5.8-r1.ebuild
new file mode 100644
index 000000000000..3de20369e57a
--- /dev/null
+++ b/dev-ros/rqt_rviz/rqt_rviz-0.5.8-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_rviz"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin embedding RViz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/pluginlib[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_cpp
+ >=dev-ros/qt_gui_cpp-0.3
+ dev-qt/qtwidgets:5
+ dev-ros/rviz
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"